summaryrefslogtreecommitdiffstats
path: root/tools/setup_passwordless_ssh/setup.py
diff options
context:
space:
mode:
authorkshithijiyer <kshithij.ki@gmail.com>2019-08-05 18:05:34 +0530
committerBala Konda Reddy M <bmekala@redhat.com>2019-11-22 16:28:55 +0000
commit0702c89a4ce4a613aa096e99aaa96398375c705c (patch)
tree8c567d0d62e7e3e2408289b0aa31c9c01fa393ff /tools/setup_passwordless_ssh/setup.py
parent037994f9835cafe248e8a78e4cb875f01116f1ef (diff)
[Tool] Adding tool to setup passwordless ssh from glusto-test conf file.
As glusto-tests needs passwordless ssh configured for all severs and clients. This can sometime be an issue when you have a large number of nodes. Adding this tool would enable us to setup passwordless ssh to all the nodes from any given glusto-tests config file. The tool is a simple python3 commandline tool which will take glusto-tests config file and password and use sshpass and ssh-copy-id to setup passwordless ssh to all nodes from the master node. Pasting the help menu of the tool to give a better picture of what can be done with the tool. usage: setup_passwordless_ssh [-h] [-c CONFIG_FILE] [-p PASSWORD] [-u USERNAME] Tool to setup passwordless ssh to all nodes. optional arguments: -h, --help show this help message and exit -c CONFIG_FILE, --config_file CONFIG_FILE A glusto-tests configuration file. -p PASSWORD, --password PASSWORD Password of servers. -u USERNAME, --username USERNAME User to be used to setup passwordless ssh. Change-Id: I491cdd975719e29b7e8f43ce548b42f2ad59a4b9 Signed-off-by: kshithijiyer <kshithij.ki@gmail.com>
Diffstat (limited to 'tools/setup_passwordless_ssh/setup.py')
-rw-r--r--tools/setup_passwordless_ssh/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/setup_passwordless_ssh/setup.py b/tools/setup_passwordless_ssh/setup.py
new file mode 100644
index 000000000..6a8a49936
--- /dev/null
+++ b/tools/setup_passwordless_ssh/setup.py
@@ -0,0 +1,31 @@
+#!/usr/bin/python3
+# Copyright (C) 2019 Red Hat, Inc. <http://www.redhat.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY :or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+from setuptools import setup
+
+setup(
+ name='setup_passwordless_ssh',
+ author='Red Hat, Inc.',
+ author_email='gluster-devel@gluster.org',
+ url='http://www.gluster.org',
+ license='GPLv3+',
+ description=("Tool to setup passwordless ssh to all nodes."),
+ py_modules=['setup_passwordless_ssh'],
+ entry_points="""
+ [console_scripts]
+ setup_passwordless_ssh = setup_passwordless_ssh:main
+ """
+)