summaryrefslogtreecommitdiffstats
path: root/tools/setup_passwordless_ssh/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'tools/setup_passwordless_ssh/setup.py')
-rw-r--r--tools/setup_passwordless_ssh/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/setup_passwordless_ssh/setup.py b/tools/setup_passwordless_ssh/setup.py
new file mode 100644
index 000000000..6a8a49936
--- /dev/null
+++ b/tools/setup_passwordless_ssh/setup.py
@@ -0,0 +1,31 @@
+#!/usr/bin/python3
+# Copyright (C) 2019 Red Hat, Inc. <http://www.redhat.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY :or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+from setuptools import setup
+
+setup(
+ name='setup_passwordless_ssh',
+ author='Red Hat, Inc.',
+ author_email='gluster-devel@gluster.org',
+ url='http://www.gluster.org',
+ license='GPLv3+',
+ description=("Tool to setup passwordless ssh to all nodes."),
+ py_modules=['setup_passwordless_ssh'],
+ entry_points="""
+ [console_scripts]
+ setup_passwordless_ssh = setup_passwordless_ssh:main
+ """
+)