summaryrefslogtreecommitdiffstats
path: root/glustolibs-gluster/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'glustolibs-gluster/setup.py')
-rw-r--r--glustolibs-gluster/setup.py12
1 files changed, 7 insertions, 5 deletions
diff --git a/glustolibs-gluster/setup.py b/glustolibs-gluster/setup.py
index b4b1cf170..05e59fde6 100644
--- a/glustolibs-gluster/setup.py
+++ b/glustolibs-gluster/setup.py
@@ -1,5 +1,5 @@
-#!/usr/bin/python
-# Copyright (c) 2016 Red Hat, Inc.
+#!/usr/bin/env python
+# Copyright (c) 2016-2020 Red Hat, Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -26,7 +26,7 @@ setup(
name=name,
version=version,
description='Glusto - Red Hat Gluster Libraries',
- license='GPLv2+',
+ license='GPLv3+',
author='Red Hat, Inc.',
author_email='gluster-devel@gluster.org',
url='http://www.gluster.org',
@@ -35,7 +35,7 @@ setup(
'Development Status :: 4 - Beta'
'Environment :: Console'
'Intended Audience :: Developers'
- 'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)'
+ 'License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)'
'Operating System :: POSIX :: Linux'
'Programming Language :: Python'
'Programming Language :: Python :: 2'
@@ -49,6 +49,8 @@ setup(
)
try:
- dir_util.copy_tree('./gdeploy_configs', '/usr/share/glustolibs/gdeploy_configs')
+ for srcdir, destdir in (('./gdeploy_configs', '/usr/share/glustolibs/gdeploy_configs'),
+ ('./scripts', '/usr/share/glustolibs/scripts/')):
+ dir_util.copy_tree(srcdir, destdir)
except:
pass