summaryrefslogtreecommitdiffstats
path: root/xlators/features/ganesha/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/ganesha/src/Makefile.am')
-rw-r--r--xlators/features/ganesha/src/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/xlators/features/ganesha/src/Makefile.am b/xlators/features/ganesha/src/Makefile.am
new file mode 100644
index 00000000000..d42b68f8440
--- /dev/null
+++ b/xlators/features/ganesha/src/Makefile.am
@@ -0,0 +1,18 @@
+xlator_LTLIBRARIES = ganesha.la
+
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+
+noinst_HEADERS = ganesha.h ganesha-mem-types.h
+
+ganesha_la_LDFLAGS = -module -avoid-version
+
+ganesha_la_SOURCES = ganesha.c
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
+ -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS)\
+ -DGANESHA_DIR=\"$(sysconfdir)/ganesha\" \
+ -DGYSNCD_PREFIX=\"$(libexecdir)/glusterfs\"
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+CLEANFILES =