summaryrefslogtreecommitdiffstats
path: root/xlators/experimental/posix2/common/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/experimental/posix2/common/src/Makefile.am')
-rw-r--r--xlators/experimental/posix2/common/src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/xlators/experimental/posix2/common/src/Makefile.am b/xlators/experimental/posix2/common/src/Makefile.am
new file mode 100644
index 00000000000..465f2f2ba32
--- /dev/null
+++ b/xlators/experimental/posix2/common/src/Makefile.am
@@ -0,0 +1,13 @@
+lib_LTLIBRARIES = libposix2common.la
+
+posix2_common_sources = posix2-common.c
+
+libposix2common_la_SOURCES = $(posix2_common_sources)
+libposix2common_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+libposix2common_la_CFLAGS = -Wall $(GF_CFLAGS)
+
+libposix2common_la_CPPFLAGS = $(GF_CPPFLAGS)
+libposix2common_la_CPPFLAGS += -I$(top_srcdir)/libglusterfs/src
+
+CLEANFILES = \ No newline at end of file