summaryrefslogtreecommitdiffstats
path: root/xlators/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/Makefile.am')
-rw-r--r--xlators/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/xlators/Makefile.am b/xlators/Makefile.am
index ea1be844ef4..876a31f8e81 100644
--- a/xlators/Makefile.am
+++ b/xlators/Makefile.am
@@ -2,8 +2,15 @@ if ENABLE_EXPERIMENTAL
EXPERIMENTAL = experimental
endif
-SUBDIRS = cluster storage protocol performance debug features encryption mount nfs mgmt system \
- playground meta $(EXPERIMENTAL)
+if BUILD_GNFS
+ GNFS_DIR = nfs
+endif
+
+DIST_SUBDIRS = cluster storage protocol performance debug features encryption \
+ mount nfs mgmt system playground meta experimental
+
+SUBDIRS = cluster storage protocol performance debug features encryption \
+ mount ${GNFS_DIR} mgmt system playground meta $(EXPERIMENTAL)
EXTRA_DIST = xlator.sym