summaryrefslogtreecommitdiffstats
path: root/xlators/Makefile.am
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2017-03-27 16:09:56 -0400
committerKaleb KEITHLEY <kkeithle@redhat.com>2017-04-28 14:08:41 +0000
commit83abcba6b42f94eb5a6495a634d4055362a9d79d (patch)
tree401e7638258acf9ef4c04af00a0bbfc443b570e3 /xlators/Makefile.am
parentab88f655e6423f51e2f2fac9265ff4d4f5c3e579 (diff)
build: conditionally build legacy gNFS server and associated sub-packaging
Plus some additional logic in glusterd to ensure gnfs (glusterfs) daemons are never started if server/nfs xlator is not installed. As a service, nfs is still initialized. The glusterfs-gnfs RPM may be installed or uninstalled independent of anything else, including on a system where gluster is actively running, so the existence of the xlator is always tested before trying to start gnfs. Change-Id: I56743ad1cb36a84917226d7d26cb9d015d441e66 BUG: 1326219 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: https://review.gluster.org/16958 Smoke: Gluster Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.org> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Diffstat (limited to 'xlators/Makefile.am')
-rw-r--r--xlators/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/xlators/Makefile.am b/xlators/Makefile.am
index ea1be844ef4..876a31f8e81 100644
--- a/xlators/Makefile.am
+++ b/xlators/Makefile.am
@@ -2,8 +2,15 @@ if ENABLE_EXPERIMENTAL
EXPERIMENTAL = experimental
endif
-SUBDIRS = cluster storage protocol performance debug features encryption mount nfs mgmt system \
- playground meta $(EXPERIMENTAL)
+if BUILD_GNFS
+ GNFS_DIR = nfs
+endif
+
+DIST_SUBDIRS = cluster storage protocol performance debug features encryption \
+ mount nfs mgmt system playground meta experimental
+
+SUBDIRS = cluster storage protocol performance debug features encryption \
+ mount ${GNFS_DIR} mgmt system playground meta $(EXPERIMENTAL)
EXTRA_DIST = xlator.sym