summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rpc/xdr/src/Makefile.am')
-rw-r--r--rpc/xdr/src/Makefile.am72
1 files changed, 36 insertions, 36 deletions
diff --git a/rpc/xdr/src/Makefile.am b/rpc/xdr/src/Makefile.am
index af9e15cfddf..48aaa7ba775 100644
--- a/rpc/xdr/src/Makefile.am
+++ b/rpc/xdr/src/Makefile.am
@@ -23,91 +23,91 @@ CLEANFILES = $(XDRSOURCES) $(XDRHEADERS)
EXTRA_DIST = $(XDRGENFILES)
glusterfs3-xdr.c: glusterfs3-xdr.x glusterfs3-xdr.h
- @if test -f ${@:.c=.x}; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x}; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
glusterfs3-xdr.h: glusterfs3-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
cli1-xdr.c: cli1-xdr.x cli1-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
cli1-xdr.h: cli1-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
nlm4-xdr.c: nlm4-xdr.x nlm4-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
nlm4-xdr.h: nlm4-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
nsm-xdr.c: nsm-xdr.x nsm-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
nsm-xdr.h: nsm-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
rpc-common-xdr.c: rpc-common-xdr.x rpc-common-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
rpc-common-xdr.h: rpc-common-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
glusterd1-xdr.c: glusterd1-xdr.x glusterd1-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
glusterd1-xdr.h: glusterd1-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
acl3-xdr.c: acl3-xdr.x acl3-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
acl3-xdr.h: acl3-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
portmap-xdr.c: portmap-xdr.x portmap-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
portmap-xdr.h: portmap-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
mount3udp.c: mount3udp.x mount3udp.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
mount3udp.h: mount3udp.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi