summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/src/Makefile.am
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-05-17 16:26:34 -0700
committerAnand Avati <avati@redhat.com>2014-05-19 21:01:20 -0700
commit0b4fc6c8bfed9ccc87d97056399a848c8990e500 (patch)
tree874ab52ba1a8d7fadf7b4ec43d708f7f06530235 /rpc/xdr/src/Makefile.am
parent7cd32c18a11d0dfeb70c276b0185e21d06a71fa5 (diff)
rpc: make sure we use relative path
In commit "618d465295df02ae6d53be1327947a210bb8b47d" we made change regarding NetBSD make by replacing `$<`, fix it accordingly. Change-Id: Ief82887253ede8216efd0ae7d5f73329f1492846 BUG: 1089172 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-on: http://review.gluster.org/7787 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Justin Clift <justin@gluster.org> Tested-by: Justin Clift <justin@gluster.org>
Diffstat (limited to 'rpc/xdr/src/Makefile.am')
-rw-r--r--rpc/xdr/src/Makefile.am72
1 files changed, 36 insertions, 36 deletions
diff --git a/rpc/xdr/src/Makefile.am b/rpc/xdr/src/Makefile.am
index af9e15cfddf..48aaa7ba775 100644
--- a/rpc/xdr/src/Makefile.am
+++ b/rpc/xdr/src/Makefile.am
@@ -23,91 +23,91 @@ CLEANFILES = $(XDRSOURCES) $(XDRHEADERS)
EXTRA_DIST = $(XDRGENFILES)
glusterfs3-xdr.c: glusterfs3-xdr.x glusterfs3-xdr.h
- @if test -f ${@:.c=.x}; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x}; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
glusterfs3-xdr.h: glusterfs3-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
cli1-xdr.c: cli1-xdr.x cli1-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
cli1-xdr.h: cli1-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
nlm4-xdr.c: nlm4-xdr.x nlm4-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
nlm4-xdr.h: nlm4-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
nsm-xdr.c: nsm-xdr.x nsm-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
nsm-xdr.h: nsm-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
rpc-common-xdr.c: rpc-common-xdr.x rpc-common-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
rpc-common-xdr.h: rpc-common-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
glusterd1-xdr.c: glusterd1-xdr.x glusterd1-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
glusterd1-xdr.h: glusterd1-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
acl3-xdr.c: acl3-xdr.x acl3-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
acl3-xdr.h: acl3-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
portmap-xdr.c: portmap-xdr.x portmap-xdr.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
portmap-xdr.h: portmap-xdr.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi
mount3udp.c: mount3udp.x mount3udp.h
- @if test -f ${@:.c=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source $(top_srcdir)/rpc/xdr/src/${@:.c=.x} ; \
fi
mount3udp.h: mount3udp.x
- @if test -f ${@:.h=.x} ; then \
- $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
+ @if test -f $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header $(top_srcdir)/rpc/xdr/src/${@:.h=.x} ; \
fi