summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am23
1 files changed, 14 insertions, 9 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index e827dde0bd9..a1c657659f3 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -16,7 +16,9 @@ SUBDIRS = init.d systemd benchmarking hook-scripts $(OCF_SUBDIR) LinuxRPM \
confdir = $(sysconfdir)/glusterfs
if WITH_SERVER
conf_DATA = glusterfs-logrotate gluster-rsyslog-7.2.conf gluster-rsyslog-5.8.conf \
- logger.conf.example glusterfs-georep-logrotate group-virt.example group-metadata-cache group-gluster-block group-nl-cache
+ logger.conf.example glusterfs-georep-logrotate group-virt.example \
+ group-metadata-cache group-gluster-block group-nl-cache \
+ group-db-workload
endif
voldir = $(sysconfdir)/glusterfs
@@ -37,14 +39,15 @@ endif
EXTRA_DIST = glusterfs-logrotate gluster-rsyslog-7.2.conf gluster-rsyslog-5.8.conf \
logger.conf.example glusterfs-georep-logrotate group-virt.example \
- group-metadata-cache group-gluster-block group-nl-cache specgen.scm \
- glusterfs-mode.el glusterfs.vim migrate-unify-to-distribute.sh \
- backend-xattr-sanitize.sh backend-cleanup.sh disk_usage_sync.sh \
- clear_xattrs.sh glusterd-sysconfig glusterd.vol \
- post-upgrade-script-for-quota.sh pre-upgrade-script-for-quota.sh \
- command-completion/gluster.bash command-completion/Makefile \
- command-completion/README stop-all-gluster-processes.sh clang-checker.sh \
- mount-shared-storage.sh control-cpu-load.sh control-mem.sh
+ group-metadata-cache group-gluster-block group-nl-cache \
+ group-db-workload specgen.scm glusterfs-mode.el glusterfs.vim \
+ migrate-unify-to-distribute.sh backend-xattr-sanitize.sh \
+ backend-cleanup.sh disk_usage_sync.sh clear_xattrs.sh \
+ glusterd-sysconfig glusterd.vol post-upgrade-script-for-quota.sh \
+ pre-upgrade-script-for-quota.sh command-completion/gluster.bash \
+ command-completion/Makefile command-completion/README \
+ stop-all-gluster-processes.sh clang-checker.sh mount-shared-storage.sh \
+ control-cpu-load.sh control-mem.sh
if WITH_SERVER
install-data-local:
@@ -62,4 +65,6 @@ install-data-local:
$(DESTDIR)$(GLUSTERD_WORKDIR)/groups/gluster-block
$(INSTALL_DATA) $(top_srcdir)/extras/group-nl-cache \
$(DESTDIR)$(GLUSTERD_WORKDIR)/groups/nl-cache
+ $(INSTALL_DATA) $(top_srcdir)/extras/group-db-workload \
+ $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/db-workload
endif