summaryrefslogtreecommitdiffstats
path: root/xlators/system/posix-acl/src/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@gluster.com>2011-07-01 17:18:10 +0000
committerAnand Avati <avati@gluster.com>2011-07-08 02:26:11 -0700
commit04ed499a8eef1c77c491227941d187778fb5c2e4 (patch)
tree7ba88ae7d30a01c22bba8e8c70abc6de301ce125 /xlators/system/posix-acl/src/Makefile.am
parent6433214452c5d8d3ae63c5f4f578862be348ca63 (diff)
posix-acl: implementation of POSIX ACL as a translator
Signed-off-by: Anand Avati <avati@gluster.com> BUG: 2815 (Server-enforced ACLs) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=2815
Diffstat (limited to 'xlators/system/posix-acl/src/Makefile.am')
-rw-r--r--xlators/system/posix-acl/src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/xlators/system/posix-acl/src/Makefile.am b/xlators/system/posix-acl/src/Makefile.am
new file mode 100644
index 00000000000..57ff27e70d5
--- /dev/null
+++ b/xlators/system/posix-acl/src/Makefile.am
@@ -0,0 +1,13 @@
+xlator_LTLIBRARIES = posix-acl.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/system
+posix_acl_la_LDFLAGS = -module -avoidversion
+posix_acl_la_SOURCES = posix-acl.c posix-acl-xattr.c
+posix_acl_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = posix-acl.h posix-acl-xattr.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS)\
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)\
+ -L$(xlatordir)/
+
+CLEANFILES =