summaryrefslogtreecommitdiffstats
path: root/xlators/protocol/client/src/Makefile.am
diff options
context:
space:
mode:
authorAnuradha Talur <atalur@redhat.com>2016-04-27 15:32:16 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2016-04-30 17:21:07 -0700
commit93eaeb9c93be3232f24e840044d560f9f0e66f71 (patch)
tree4499267cb96472d06067e9856cff1905e8003a49 /xlators/protocol/client/src/Makefile.am
parent0d23f5207337fa54be57939eb8d70fe835d4658b (diff)
protocol/client : Refactoring functions
These changes are made to accommodate compound fops. The new functions that are added pack the arguments required to perform the fops. These will be used both by normal fops and compound ones. Change-Id: I44d9cef8ff1d33aa2f5661689c8e9386d87b2007 BUG: 1303829 Signed-off-by: Anuradha Talur <atalur@redhat.com> Reviewed-on: http://review.gluster.org/13963 Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com> Smoke: Gluster Build System <jenkins@build.gluster.com> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Diffstat (limited to 'xlators/protocol/client/src/Makefile.am')
-rw-r--r--xlators/protocol/client/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/xlators/protocol/client/src/Makefile.am b/xlators/protocol/client/src/Makefile.am
index 7dbcf2a833d..75acbc9e877 100644
--- a/xlators/protocol/client/src/Makefile.am
+++ b/xlators/protocol/client/src/Makefile.am
@@ -9,9 +9,9 @@ client_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
$(top_builddir)/rpc/xdr/src/libgfxdr.la
client_la_SOURCES = client.c client-helpers.c client-rpc-fops.c \
- client-handshake.c client-callback.c client-lk.c
+ client-handshake.c client-callback.c client-lk.c client-common.c
-noinst_HEADERS = client.h client-mem-types.h client-messages.h
+noinst_HEADERS = client.h client-mem-types.h client-messages.h client-common.h
AM_CPPFLAGS = $(GF_CPPFLAGS) \
-I$(top_srcdir)/libglusterfs/src \