summaryrefslogtreecommitdiffstats
path: root/xlators/performance/io-cache/src/Makefile.am
diff options
context:
space:
mode:
authorRaghavendra G <raghavendra@gluster.com>2009-10-26 03:01:33 +0000
committerAnand V. Avati <avati@dev.gluster.com>2009-10-28 01:46:27 -0700
commit3809bb1bbd617dbde1d943dbcf6b0346329187b6 (patch)
treec326390674d9120a731d01345d842e0e803e739a /xlators/performance/io-cache/src/Makefile.am
parent78d281d6026ad1ebe8cc65c4396055902369ea89 (diff)
performance/io-cache: change data structure used to store page-cache.
- io-cache uses rbtree based hash tables to store page-cache instead of lists. Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 335 (Io-cache optimization) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=335
Diffstat (limited to 'xlators/performance/io-cache/src/Makefile.am')
-rw-r--r--xlators/performance/io-cache/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/performance/io-cache/src/Makefile.am b/xlators/performance/io-cache/src/Makefile.am
index b1bf5bfbf71..e3d816f1542 100644
--- a/xlators/performance/io-cache/src/Makefile.am
+++ b/xlators/performance/io-cache/src/Makefile.am
@@ -9,6 +9,6 @@ io_cache_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
noinst_HEADERS = io-cache.h
AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
- -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)
+ -I$(top_srcdir)/libglusterfs/src -I$(CONTRIBDIR)/rbtree -shared -nostartfiles $(GF_CFLAGS)
CLEANFILES =