summaryrefslogtreecommitdiffstats
path: root/xlators/performance/decompounder/src/Makefile.am
diff options
context:
space:
mode:
authorAnuradha Talur <atalur@redhat.com>2016-04-21 17:20:09 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2016-04-25 23:47:28 -0700
commit9996f95b28b3782887b7c233cdc0ba686c38b245 (patch)
tree5fa681f25b95dd9aeec88f3bf86adbc98bd2c1d3 /xlators/performance/decompounder/src/Makefile.am
parent2dc22adbf3361bdab10924943371492cc2817d8a (diff)
performance/decompounder: Introducing decompounder xlator
This xlator decompounds the compound fops received, and executes them serially. Change-Id: Ieddcec3c2983dd9ca7919ba9d7ecaa5192a5f489 BUG: 1303829 Signed-off-by: Anuradha Talur <atalur@redhat.com> Reviewed-on: http://review.gluster.org/13577 Smoke: Gluster Build System <jenkins@build.gluster.com> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Diffstat (limited to 'xlators/performance/decompounder/src/Makefile.am')
-rw-r--r--xlators/performance/decompounder/src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/xlators/performance/decompounder/src/Makefile.am b/xlators/performance/decompounder/src/Makefile.am
new file mode 100644
index 00000000000..693fe0aa5c2
--- /dev/null
+++ b/xlators/performance/decompounder/src/Makefile.am
@@ -0,0 +1,16 @@
+xlator_LTLIBRARIES = decompounder.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/performance
+
+decompounder_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
+
+decompounder_la_SOURCES = decompounder.c
+decompounder_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = decompounder-mem-types.h decompounder-messages.h \
+ decompounder.h
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+CLEANFILES =