summaryrefslogtreecommitdiffstats
path: root/xlators/performance/Makefile.am
diff options
context:
space:
mode:
authorAnand Avati <avati@gluster.com>2011-09-24 16:14:11 +0530
committerAnand Avati <avati@redhat.com>2012-02-20 21:14:28 -0800
commitc41a9d1c3fe4002bdf8849c4e8ae7c2e10841c69 (patch)
treefc206a62f4b044846bf710db85f2cc046c0551fe /xlators/performance/Makefile.am
parent1206437fcfc1f3e1bd4a6faec3341c240bae5cf2 (diff)
md-cache: meta-data caching translator
This is a metadata caching translator which is well integrated with glusterfs core framework and leverages some of the recent protocol changes to do a better job at caching. - It uses the attributes returned along callbacks of all calls to update its attribute cache as frequently as possible without issuing calls on its own (i.e, very low overhead) - It caches attributes returned via readdirp into the inode contexts corresponding to those entries (i.e, well integrated) - It caches and updates xattrs and not just inode attributes (i.e, eliminates the need for a separate xattr-prefetch translator) In its current form it has a timeout based consistency model Change-Id: I891f6225c1a4c08bb111e287571d5f6d326dbe97 BUG: 765785 Reviewed-on: http://review.gluster.com/2713 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'xlators/performance/Makefile.am')
-rw-r--r--xlators/performance/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/performance/Makefile.am b/xlators/performance/Makefile.am
index e91d5f6efc8..2fc145e4021 100644
--- a/xlators/performance/Makefile.am
+++ b/xlators/performance/Makefile.am
@@ -1,3 +1,3 @@
-SUBDIRS = write-behind read-ahead io-threads io-cache symlink-cache quick-read stat-prefetch
+SUBDIRS = write-behind read-ahead io-threads io-cache symlink-cache quick-read stat-prefetch md-cache
CLEANFILES =