summaryrefslogtreecommitdiffstats
path: root/xlators/features/marker/utils/src/Makefile.am
diff options
context:
space:
mode:
authorCsaba Henk <csaba@gluster.com>2011-09-13 13:12:38 +0200
committerVijay Bellur <vijay@gluster.com>2011-09-22 05:23:54 -0700
commit7e04913aa6f4ddb45e95099ef648564bf90da0b3 (patch)
treec456a74980b0dcc7eaa6338ee46454a55bf16156 /xlators/features/marker/utils/src/Makefile.am
parent2ab00369e7ef99d287dad5301d2f334dcfd67a70 (diff)
gsyncd: control rsync target
- require/perform rsync invocation with unprotected args (so that target is revealed to gateway program) - make use of some procfs wizardry to find gsyncd sibling and match rsync target against its working directory Change-Id: Iae1e39b0e61f22563c0f2a2e0605567e0d1902df BUG: 2825 Reviewed-on: http://review.gluster.com/461 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vijay@gluster.com>
Diffstat (limited to 'xlators/features/marker/utils/src/Makefile.am')
-rw-r--r--xlators/features/marker/utils/src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/xlators/features/marker/utils/src/Makefile.am b/xlators/features/marker/utils/src/Makefile.am
index 74e2b3ef516..73c99cb76d8 100644
--- a/xlators/features/marker/utils/src/Makefile.am
+++ b/xlators/features/marker/utils/src/Makefile.am
@@ -2,12 +2,14 @@ gsyncddir = $(libexecdir)/glusterfs
gsyncd_PROGRAMS = gsyncd
-gsyncd_SOURCES = gsyncd.c
+gsyncd_SOURCES = gsyncd.c procdiggy.c
gsyncd_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
gsyncd_LDFLAGS = $(GF_LDFLAGS) $(GF_GLUSTERFS_LDFLAGS)
+noinst_HEADERS = procdiggy.h
+
AM_CFLAGS = -fPIC -Wall -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS)\
-I$(top_srcdir)/libglusterfs/src\
-DGSYNCD_PREFIX=\"$(libexecdir)/glusterfs\"\