summaryrefslogtreecommitdiffstats
path: root/tools/glusterfind/src/Makefile.am
diff options
context:
space:
mode:
authorAravinda VK <avishwan@redhat.com>2015-04-30 12:28:17 +0530
committerVijay Bellur <vbellur@redhat.com>2015-05-08 21:59:10 -0700
commite88837ed0ff68093912c2b8e996c5851c53674ca (patch)
tree854c30520331099685b29e28e8b8dd15fa357d3a /tools/glusterfind/src/Makefile.am
parent2676c402bc47ee89b763393e496a013e82d76e54 (diff)
tools/glusterfind: GFID to Path conversion using Changelog
Records fop information collected from Changelogs in sqlite database. This is only working database, not required after processing. After post processing, output file is generated by reading these database files. This is applicable only in incremental run, When a changelog is parsed, all the details are saved in Db. GFID to Path is converted to those files for which information is available in Changelogs. For all the failed cases, it tries to convert to Path using Pgfid, if not found GFID to Path is done using find. BUG: 1201284 Change-Id: I53f168860dae15a0149004835e67f97aebd822be Signed-off-by: Aravinda VK <avishwan@redhat.com> Reviewed-on: http://review.gluster.org/10463 Reviewed-by: Kotresh HR <khiremat@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'tools/glusterfind/src/Makefile.am')
-rw-r--r--tools/glusterfind/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/glusterfind/src/Makefile.am b/tools/glusterfind/src/Makefile.am
index 7b819828d97..541ff946c04 100644
--- a/tools/glusterfind/src/Makefile.am
+++ b/tools/glusterfind/src/Makefile.am
@@ -1,7 +1,7 @@
glusterfinddir = $(libexecdir)/glusterfs/glusterfind
glusterfind_PYTHON = conf.py utils.py __init__.py \
- main.py libgfchangelog.py
+ main.py libgfchangelog.py changelogdata.py
glusterfind_SCRIPTS = changelog.py nodeagent.py \
brickfind.py
@@ -9,6 +9,6 @@ glusterfind_SCRIPTS = changelog.py nodeagent.py \
glusterfind_DATA = tool.conf
EXTRA_DIST = changelog.py nodeagent.py brickfind.py \
- tool.conf
+ tool.conf changelogdata.py
CLEANFILES =