summaryrefslogtreecommitdiffstats
path: root/tools/glusterfind/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2015-06-18 00:21:59 +0200
committerNiels de Vos <ndevos@redhat.com>2015-08-25 08:50:55 -0700
commit55b44094436bc8630b6c3ff2d232e6551d40630c (patch)
treedff3f88c49ab1eddf9c61c051381f158c57bf13a /tools/glusterfind/Makefile.am
parent130697b8b706432153d9a0fda49b896065289aaa (diff)
rpm: include required directory for glusterfind
The directory was marked as %ghost, which causes the following installation failure: Error unpacking rpm package glusterfs-server-3.8dev-0.446.git45e13fe.el7.centos.x86_64 error: unpacking of archive failed on file /var/lib/glusterd/hooks/1/delete/post/S57glusterfind-delete-post.py;5581f20e: cpio: open Also, *all* Python files should be part of the RPM package. This includes generated .pyc and .pyo files. BUG: 1256307 Change-Id: Iee74905b101912c4a845257742c470c3fe42ce2a Signed-off-by: Niels de Vos <ndevos@redhat.com> Signed-off-by: Aravinda VK <avishwan@redhat.com> Reviewed-on: http://review.gluster.org/11298 Reviewed-on: http://review.gluster.org/12000 Tested-by: NetBSD Build System <jenkins@build.gluster.org> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'tools/glusterfind/Makefile.am')
-rw-r--r--tools/glusterfind/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tools/glusterfind/Makefile.am b/tools/glusterfind/Makefile.am
index c5a05d61061..514c37c14ad 100644
--- a/tools/glusterfind/Makefile.am
+++ b/tools/glusterfind/Makefile.am
@@ -1,10 +1,20 @@
SUBDIRS = src
-EXTRA_DIST =
+EXTRA_DIST = S57glusterfind-delete-post.py
bin_SCRIPTS = glusterfind
CLEANFILES = $(bin_SCRIPTS)
+deletehookscriptsdir = $(libexecdir)/glusterfs/glusterfind/
+deletehookscripts_SCRIPTS = S57glusterfind-delete-post.py
+
+uninstall-local:
+ rm -f $(DESTDIR)$(GLUSTERD_WORKDIR)/hooks/1/delete/post/S57glusterfind-delete-post.py
+
install-data-local:
$(MKDIR_P) $(DESTDIR)$(GLUSTERD_WORKDIR)/glusterfind/.keys
+ $(MKDIR_P) $(DESTDIR)$(GLUSTERD_WORKDIR)/hooks/1/delete/post/
+ rm -f $(DESTDIR)$(GLUSTERD_WORKDIR)/hooks/1/delete/post/S57glusterfind-delete-post.py
+ ln -s $(libexecdir)/glusterfs/glusterfind/S57glusterfind-delete-post.py \
+ $(DESTDIR)$(GLUSTERD_WORKDIR)/hooks/1/delete/post/S57glusterfind-delete-post.py