summaryrefslogtreecommitdiffstats
path: root/extras/hook-scripts/Makefile.am
diff options
context:
space:
mode:
authorBrian Foster <bfoster@redhat.com>2014-01-02 14:03:18 -0500
committerKaleb KEITHLEY <kkeithle@redhat.com>2017-05-01 09:30:01 +0000
commit859669759f7fa0f2114add13660ce3bf16c77f30 (patch)
treeaf766c9376eebb0a37fe8c298f9016403b386907 /extras/hook-scripts/Makefile.am
parentc6dd1e68dfe60e747e318a9e28a067e24576fdb6 (diff)
extras/hook-scripts: SELinux brick file context management scripts
The SELinux policy for gluster defines the glusterd_brick_t type to support server side SELinux (e.g., server side labels). Add convenience hook scripts that users/packagers can install to ensure that new bricks are labeled correctly. The volume create hook script adds a new SELinux file context for each brick path and runs a restorecon to label the brick. The volume delete hook removes the per-brick SELinux file context. Change-Id: I5f102db5382d813c4d822ff74e873a7a669b41db BUG: 1047975 Signed-off-by: Brian Foster <bfoster@redhat.com> Signed-off-by: Niels de Vos <ndevos@redhat.com> Signed-off-by: Jiffin Tony Thottan <jthottan@redhat.com> Reviewed-on: https://review.gluster.org/6630 Smoke: Gluster Build System <jenkins@build.gluster.org> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.org> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Diffstat (limited to 'extras/hook-scripts/Makefile.am')
-rw-r--r--extras/hook-scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/extras/hook-scripts/Makefile.am b/extras/hook-scripts/Makefile.am
index 771b37e3fdf..26059d7dbb9 100644
--- a/extras/hook-scripts/Makefile.am
+++ b/extras/hook-scripts/Makefile.am
@@ -1,5 +1,5 @@
EXTRA_DIST = S40ufo-stop.py S56glusterd-geo-rep-create-post.sh
-SUBDIRS = add-brick set start stop reset
+SUBDIRS = add-brick create delete set start stop reset
scriptsdir = $(GLUSTERD_WORKDIR)/hooks/1/gsync-create/post/
if USE_GEOREP