summaryrefslogtreecommitdiffstats
path: root/extras/hook-scripts/Makefile.am
diff options
context:
space:
mode:
authorAravinda VK <avishwan@redhat.com>2015-05-27 18:05:35 +0530
committerVijay Bellur <vbellur@redhat.com>2015-06-12 11:35:35 -0700
commit36e3e0d92e0692c6565fba631c715654b712556d (patch)
tree3ed5ed587c1615bfab782fde0d73bf54471ed0a1 /extras/hook-scripts/Makefile.am
parente444c8f454aa791aa723016ceaa66d9eb2971dc0 (diff)
tools/glusterfind: Cleanup glusterfind dir after a volume delete
If `glusterfind delete` command was not run before volume delete, stale session directories exists in /var/lib/glusterd/glusterfind directories. Also shows these sessions in `glusterfind list` When Volume is deleted, Post hook will be run which cleans up the stale session directories BUG: 1225551 Change-Id: I54c46c30313e92c1bb4cb07918ed2029b375462c Signed-off-by: Aravinda VK <avishwan@redhat.com> Reviewed-on: http://review.gluster.org/#/c/10944 Reviewed-on: http://review.gluster.org/11186 Tested-by: NetBSD Build System <jenkins@build.gluster.org> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kotresh HR <khiremat@redhat.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'extras/hook-scripts/Makefile.am')
-rw-r--r--extras/hook-scripts/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/extras/hook-scripts/Makefile.am b/extras/hook-scripts/Makefile.am
index 771b37e3fdf..f291261d123 100644
--- a/extras/hook-scripts/Makefile.am
+++ b/extras/hook-scripts/Makefile.am
@@ -1,7 +1,11 @@
-EXTRA_DIST = S40ufo-stop.py S56glusterd-geo-rep-create-post.sh
+EXTRA_DIST = S40ufo-stop.py S56glusterd-geo-rep-create-post.sh \
+ S57glusterfind-delete-post.py
SUBDIRS = add-brick set start stop reset
scriptsdir = $(GLUSTERD_WORKDIR)/hooks/1/gsync-create/post/
if USE_GEOREP
scripts_SCRIPTS = S56glusterd-geo-rep-create-post.sh
endif
+
+deletehookscriptsdir = $(GLUSTERD_WORKDIR)/hooks/1/delete/post/
+deletehookscripts_SCRIPTS = S57glusterfind-delete-post.py