summaryrefslogtreecommitdiffstats
path: root/cli/src/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2015-04-17 06:09:15 +0200
committerRaghavendra Bhat <raghavendra@redhat.com>2015-05-19 06:23:59 -0700
commitf7b8b1c95a11a8100b3bbb2a820dcead1b094655 (patch)
treef36849c9915b65684cbfea1c6e7fc8284d6ed2c8 /cli/src/Makefile.am
parent690c87816d412cc2a6c6f735c1941810bcb700ea (diff)
Fix case mistake for MKDIR_P in Makefiles
Some makefiles used $(mkdir_p) instead of the corectly defined $(MKDIR_P). The former is substituted as an empty string, leading to possible failures depending of the user shell tolerance. NetBSD's /bin/sh seems to choke more easily than Linux's /bin/bash, but if the later does not fail, it does not created the intended directories anyway. Backport of I8caed4000f3c91cb3a685453848fb854793945ed BUG: 1138897 Change-Id: I48a24231ba90aa3e84bf433b63ae5cb50307f042 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/10278 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
Diffstat (limited to 'cli/src/Makefile.am')
-rw-r--r--cli/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/cli/src/Makefile.am b/cli/src/Makefile.am
index 434122b2a78..db1d089b8f9 100644
--- a/cli/src/Makefile.am
+++ b/cli/src/Makefile.am
@@ -29,4 +29,4 @@ $(top_builddir)/libglusterfs/src/libglusterfs.la:
$(MAKE) -C $(top_builddir)/libglusterfs/src/ all
install-data-hook:
- $(mkdir_p) $(DESTDIR)$(localstatedir)/run/gluster
+ $(MKDIR_P) $(DESTDIR)$(localstatedir)/run/gluster