summaryrefslogtreecommitdiffstats
path: root/api/src/Makefile.am
diff options
context:
space:
mode:
authorMohamed Ashiq <mliyazud@redhat.com>2015-11-10 13:18:41 +0530
committerShyamsundar Ranganathan <srangana@redhat.com>2015-11-17 07:46:37 -0800
commitf71c08b8d592fa6125fee57fb73f774ce522756c (patch)
treeb25620f5414a4df58b37ec6d9358cfaa82d2f630 /api/src/Makefile.am
parent7de355b42dc1f8313db3ffc775a0e1708ba85243 (diff)
libgfapi: To support set_volfile-server-transport type "unix"
This patch helps libgfapi to get the volfile using Unix domain socket. run the attachment file in the bug to test. The patch checks if the glfs_set_volfile_server transport is of type "unix", If It is then uses rpc_transport_unix_options_build to get the volfile. Change-Id: Ifd5d1e7c0d8cc9a906c3c3355b8977141e892a2f BUG: 1279739 Signed-off-by: Mohamed Ashiq <mliyazud@redhat.com> Signed-off-by: Humble Devassy Chirammal <hchiramm@redhat.com> Reviewed-on: http://review.gluster.org/12563 Tested-by: NetBSD Build System <jenkins@build.gluster.org> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com> Reviewed-by: Poornima G <pgurusid@redhat.com> Reviewed-by: Raghavendra Talur <rtalur@redhat.com> Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Diffstat (limited to 'api/src/Makefile.am')
-rw-r--r--api/src/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/api/src/Makefile.am b/api/src/Makefile.am
index 527b12d0850..872868aab0c 100644
--- a/api/src/Makefile.am
+++ b/api/src/Makefile.am
@@ -12,10 +12,13 @@ libgfapi_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
$(top_builddir)/rpc/xdr/src/libgfxdr.la \
$(GF_LDADD)
-libgfapi_la_CPPFLAGS = $(GF_CPPFLAGS) -D__USE_FILE_OFFSET64 \
- -I$(top_srcdir)/libglusterfs/src \
- -I$(top_srcdir)/rpc/rpc-lib/src \
- -I$(top_srcdir)/rpc/xdr/src
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
+ -I$(top_srcdir)/rpc/rpc-lib/src \
+ -I$(top_srcdir)/rpc/xdr/src \
+ -DDATADIR=\"$(localstatedir)\" \
+ -D__USE_FILE_OFFSET64
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
libgfapi_la_LDFLAGS = -version-info $(GFAPI_LT_VERSION) \
$(GFAPI_EXTRA_LDFLAGS) $(ACL_LIBS)
@@ -35,6 +38,3 @@ api_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
$(top_builddir)/rpc/xdr/src/libgfxdr.la \
$(top_builddir)/api/src/libgfapi.la
-AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
-
-AM_CFLAGS = -Wall $(GF_CFLAGS)