summaryrefslogtreecommitdiffstats
path: root/swift/1.4.8/gluster-swift-plugin.spec
diff options
context:
space:
mode:
Diffstat (limited to 'swift/1.4.8/gluster-swift-plugin.spec')
-rw-r--r--swift/1.4.8/gluster-swift-plugin.spec60
1 files changed, 60 insertions, 0 deletions
diff --git a/swift/1.4.8/gluster-swift-plugin.spec b/swift/1.4.8/gluster-swift-plugin.spec
new file mode 100644
index 00000000..746f75c5
--- /dev/null
+++ b/swift/1.4.8/gluster-swift-plugin.spec
@@ -0,0 +1,60 @@
+############################################################################################################
+# Command to build rpms.#
+# $ rpmbuild -ta %{name}-%{version}-%{release}.tar.gz #
+############################################################################################################
+# Setting up the environment. #
+# * Create a directory %{name}-%{version} under $HOME/rpmbuild/SOURCES #
+# * Copy the contents of plugins directory into $HOME/rpmbuild/SOURCES/%{name}-%{version} #
+# * tar zcvf %{name}-%{version}-%{release}.tar.gz $HOME/rpmbuild/SOURCES/%{name}-%{version} %{name}.spec #
+# For more information refer #
+# http://fedoraproject.org/wiki/How_to_create_an_RPM_package #
+############################################################################################################
+
+%define _confdir /etc/swift
+%define _swiftdir /usr/lib/python2.6/site-packages/swift
+%define _ufo_version 1.0
+%define _ufo_release 3
+
+Summary : GlusterFS Unified File and Object Storage.
+Name : gluster-swift-plugin
+Version : %{_ufo_version}
+Release : %{_ufo_release}
+Group : Application/File
+Vendor : Red Hat Inc.
+Source0 : %{name}-%{version}-%{release}.tar.gz
+Packager : gluster-users@gluster.org
+License : Apache
+BuildArch: noarch
+Requires : memcached
+Requires : openssl
+Requires : python
+Requires : gluster-swift
+
+%description
+Gluster Unified File and Object Storage unifies NAS and object storage
+technology. This provides a system for data storage that enables users to access
+the same data as an object and as a file, simplifying management and controlling
+storage costs.
+
+%prep
+%setup -q
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}/%{_swiftdir}/plugins
+mkdir -p %{buildroot}/%{_confdir}/
+
+cp constraints.py %{buildroot}/%{_swiftdir}/plugins
+cp DiskDir.py %{buildroot}/%{_swiftdir}/plugins
+cp DiskFile.py %{buildroot}/%{_swiftdir}/plugins
+cp Glusterfs.py %{buildroot}/%{_swiftdir}/plugins
+cp __init__.py %{buildroot}/%{_swiftdir}/plugins
+cp utils.py %{buildroot}/%{_swiftdir}/plugins
+
+cp -r conf/* %{buildroot}/%{_confdir}/
+
+%files
+%defattr(-,root,root)
+%{_swiftdir}/plugins
+%{_confdir}/