summaryrefslogtreecommitdiffstats
path: root/xlators/features/index/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/index/src/Makefile.am')
-rw-r--r--xlators/features/index/src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/xlators/features/index/src/Makefile.am b/xlators/features/index/src/Makefile.am
new file mode 100644
index 00000000000..5d037c7eca6
--- /dev/null
+++ b/xlators/features/index/src/Makefile.am
@@ -0,0 +1,15 @@
+xlator_LTLIBRARIES = index.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+
+index_la_LDFLAGS = -module -avoidversion
+
+index_la_SOURCES = index.c
+index_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = index.h index-mem-types.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/rpc/xdr/src \
+ -I$(top_srcdir)/rpc/rpc-lib/src -shared -nostartfiles $(GF_CFLAGS)
+
+CLEANFILES =