summaryrefslogtreecommitdiffstats
path: root/xlators/features/glupy/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/glupy/src/Makefile.am')
-rw-r--r--xlators/features/glupy/src/Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/xlators/features/glupy/src/Makefile.am b/xlators/features/glupy/src/Makefile.am
index 9b39b4687a3..f1802c3545e 100644
--- a/xlators/features/glupy/src/Makefile.am
+++ b/xlators/features/glupy/src/Makefile.am
@@ -3,17 +3,25 @@ xlator_LTLIBRARIES = glupy.la
# Ensure GLUSTER_PYTHON_PATH is passed to glupy.so
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
glupydir = $(xlatordir)/glupy
-AM_CPPFLAGS = $(PYTHONDEV_CPPFLAGS) $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src -isystem $(BUILD_PYTHON_INC)
+
+AM_CPPFLAGS = $(PYTHONDEV_CPPFLAGS) $(GF_CPPFLAGS) \
+ -I$(top_srcdir)/libglusterfs/src \
+ -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \
+ -isystem $(BUILD_PYTHON_INC)
+
AM_CFLAGS = $(PYTHONDEV_CPPFLAGS) -Wall -fno-strict-aliasing \
- -DGLUSTER_PYTHON_PATH=\"$(glupydir)\" \
- -DPATH_GLUSTERFS_GLUPY_MODULE=\"${xlatordir}/glupy${shrext_cmds}\" \
- $(GF_CFLAGS)
+ -DGLUSTER_PYTHON_PATH=\"$(glupydir)\" \
+ -DPATH_GLUSTERFS_GLUPY_MODULE=\"${xlatordir}/glupy${shrext_cmds}\" \
+ $(GF_CFLAGS)
# Flags to build glupy.so with
-glupy_la_LDFLAGS = $(PYTHONDEV_LDFLAGS) -module -avoid-version -nostartfiles -export-symbols $(top_srcdir)/xlators/features/glupy/src/glupy.sym
+glupy_la_LDFLAGS = $(PYTHONDEV_LDFLAGS) -module -avoid-version \
+ -nostartfiles -export-symbols \
+ $(top_srcdir)/xlators/features/glupy/src/glupy.sym
+
glupy_la_SOURCES = glupy.c
glupy_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
- -lpthread -l$(BUILD_PYTHON_LIB)
+ -lpthread -l$(BUILD_PYTHON_LIB)
noinst_HEADERS = glupy.h