summaryrefslogtreecommitdiffstats
path: root/xlators/experimental/dht2/dht2-client/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/experimental/dht2/dht2-client/src/Makefile.am')
-rw-r--r--xlators/experimental/dht2/dht2-client/src/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/xlators/experimental/dht2/dht2-client/src/Makefile.am b/xlators/experimental/dht2/dht2-client/src/Makefile.am
new file mode 100644
index 00000000000..39132994d08
--- /dev/null
+++ b/xlators/experimental/dht2/dht2-client/src/Makefile.am
@@ -0,0 +1,19 @@
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/experimental
+xlator_LTLIBRARIES = dht2c.la
+
+dht2c_sources = dht2-client-main.c
+
+dht2common_sources = $(top_srcdir)/xlators/experimental/dht2/dht2-common/src/dht2-common-map.c
+
+dht2c_la_SOURCES = $(dht2c_sources) $(dht2common_sources)
+dht2c_la_LDFLAGS = -module -avoid-version
+dht2c_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+AM_CPPFLAGS = $(GF_CPPFLAGS)
+AM_CPPFLAGS += -I$(top_srcdir)/xlators/experimental/dht2/dht2-common/src/
+AM_CPPFLAGS += -I$(top_srcdir)/libglusterfs/src
+AM_CPPFLAGS += -I$(top_srcdir)/xlators/lib/src
+
+CLEANFILES =