summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 3 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 7392b706bb8..5fe304abf4d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1196,14 +1196,9 @@ AC_ARG_ENABLE([cmocka],
[Enable cmocka build options.]))
if test "x$enable_cmocka" = "xyes"; then
BUILD_UNITTEST="yes"
- PKG_CHECK_MODULES([UNITTEST], [cmocka], [],[
- AC_CHECK_LIB([cmocka], [mock_assert], [
- UNITTEST_LDFLAGS="-lcmocka -lgcov"
- UNITTEST_CFLAGS="-Wall -Werror"
- ], [
- AC_MSG_ERROR([cmocka library is required to build glusterfs])
- ])
- ])
+ PKG_CHECK_MODULES([UNITTEST], [cmocka >= 1.0.1], [BUILD_UNITTEST="yes"],
+ [AC_MSG_ERROR([cmocka library is required to build glusterfs])]
+ )
fi
AM_CONDITIONAL([UNITTEST], [test x$BUILD_UNITTEST = xyes])