summaryrefslogtreecommitdiffstats
path: root/xlators/storage/posix/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amar@gluster.com>2011-07-12 05:16:46 +0000
committerAnand Avati <avati@gluster.com>2011-07-12 05:37:11 -0700
commit2c688714a2a081fc1be30febcd839caf8e201456 (patch)
treed031e44e46cf92ea1af13773d3daee8e965fc03b /xlators/storage/posix/src/Makefile.am
parent79f4135994e5051c711595c791d5831bdad24738 (diff)
storage/posix: move the helper functions to separate file
helper functions were more than 800 lines Signed-off-by: Amar Tumballi <amar@gluster.com> Signed-off-by: Anand Avati <avati@gluster.com> BUG: 3158 (Keep code more readable and clean) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=3158
Diffstat (limited to 'xlators/storage/posix/src/Makefile.am')
-rw-r--r--xlators/storage/posix/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/storage/posix/src/Makefile.am b/xlators/storage/posix/src/Makefile.am
index b8d1668aee9..90ea1fd51ee 100644
--- a/xlators/storage/posix/src/Makefile.am
+++ b/xlators/storage/posix/src/Makefile.am
@@ -4,7 +4,7 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/storage
posix_la_LDFLAGS = -module -avoidversion
-posix_la_SOURCES = posix.c
+posix_la_SOURCES = posix.c posix-helpers.c
posix_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
noinst_HEADERS = posix.h posix-mem-types.h