summaryrefslogtreecommitdiffstats
path: root/xlators/features/thin-arbiter/src/Makefile.am
diff options
context:
space:
mode:
authorAshish Pandey <aspandey@redhat.com>2018-02-01 12:18:38 +0530
committerAshish Pandey <aspandey@redhat.com>2018-04-25 14:34:39 +0530
commit69c35dbb4b3b92c60cbce8dff58e9d1399820b0d (patch)
tree21b876b954c54ee068788ffca19ccbc293c95e49 /xlators/features/thin-arbiter/src/Makefile.am
parent6912441543192a366f264b61d97d50faf3815a28 (diff)
feature/thin-arbiter: Implement thin-arbiter translator
Updates #352 Change-Id: I3d8caa6479dc8e48bec62a09b056971bb061f0cf Signed-off-by: Ashish Pandey <aspandey@redhat.com>
Diffstat (limited to 'xlators/features/thin-arbiter/src/Makefile.am')
-rw-r--r--xlators/features/thin-arbiter/src/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/xlators/features/thin-arbiter/src/Makefile.am b/xlators/features/thin-arbiter/src/Makefile.am
new file mode 100644
index 00000000000..7fd31a66caa
--- /dev/null
+++ b/xlators/features/thin-arbiter/src/Makefile.am
@@ -0,0 +1,24 @@
+if WITH_SERVER
+xlator_LTLIBRARIES = thin-arbiter.la
+endif
+
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+
+thin_arbiter_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
+
+thin_arbiter_la_SOURCES = thin-arbiter.c \
+ $(top_builddir)/xlators/lib/src/libxlator.c
+
+thin_arbiter_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = thin-arbiter.h thin-arbiter-mem-types.h thin-arbiter-messages.h \
+ $(top_builddir)/xlators/lib/src/libxlator.h
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) \
+ -I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/xlators/lib/src \
+ -I$(top_srcdir)/rpc/rpc-lib/src \
+ -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+CLEANFILES =