summaryrefslogtreecommitdiffstats
path: root/xlators/features/read-only/src/Makefile.am
diff options
context:
space:
mode:
authorAtin Mukherjee <amukherj@redhat.com>2014-08-30 16:15:36 +0530
committerVijay Bellur <vbellur@redhat.com>2015-03-24 06:53:11 -0700
commitef158c75d1d6fac76635e95a9a43145433169b44 (patch)
tree488c342d2890234017ac7a1ca7ca0d1485580117 /xlators/features/read-only/src/Makefile.am
parenta20101e2e4d5f5595655544cfc798eb1d445638c (diff)
read-only: read-only/worm translator should be in brick graph by default
Problem: read-only/worm translator is not loaded by default in brick graph because of which when read-only option is set through volume set volume still remains writable untill the bricks are restarted as the translator does not have an inmemory flag to decide whether the read-only/worm option is turned or not. Solution: read-only/worm should be loaded by default in brick graph and the read-only/worm option can be toggled through volume set command. read-only/worm translator now' has an in-memory flag to decide whether the volume is read-only or not and based on that either reject the fop or proceed. Change-Id: Ic79328698f6a72c50433cff15ecadb1a92acc643 BUG: 1134822 Signed-off-by: Atin Mukherjee <amukherj@redhat.com> Reviewed-on: http://review.gluster.org/8571 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'xlators/features/read-only/src/Makefile.am')
-rw-r--r--xlators/features/read-only/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/features/read-only/src/Makefile.am b/xlators/features/read-only/src/Makefile.am
index 4c146213742..209e4208af0 100644
--- a/xlators/features/read-only/src/Makefile.am
+++ b/xlators/features/read-only/src/Makefile.am
@@ -2,7 +2,7 @@ xlator_LTLIBRARIES = read-only.la worm.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
-noinst_HEADERS = read-only-common.h
+noinst_HEADERS = read-only.h read-only-mem-types.h read-only-common.h
read_only_la_LDFLAGS = -module -avoid-version