summaryrefslogtreecommitdiffstats
path: root/xlators/features/read-only/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amar@gluster.com>2010-03-24 04:04:02 +0000
committerAnand V. Avati <avati@dev.gluster.com>2010-03-24 05:42:16 -0700
commit1a15248382e53e5c04cb6235144001d697f6b09b (patch)
tree069d06cd917821905bc2df34396eddda119a4a92 /xlators/features/read-only/src/Makefile.am
parent1e55e8f29b4cebb3398a46e36b8791980bb1db6d (diff)
new 'features/read-only' module added
Signed-off-by: Amar Tumballi <amar@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 712 (mount.glusterfs script doesn't handle 'ro' option) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=712
Diffstat (limited to 'xlators/features/read-only/src/Makefile.am')
-rw-r--r--xlators/features/read-only/src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/xlators/features/read-only/src/Makefile.am b/xlators/features/read-only/src/Makefile.am
new file mode 100644
index 00000000000..15f49966ff7
--- /dev/null
+++ b/xlators/features/read-only/src/Makefile.am
@@ -0,0 +1,13 @@
+xlator_LTLIBRARIES = read-only.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+
+read_only_la_LDFLAGS = -module -avoidversion
+
+read_only_la_SOURCES = read-only.c
+read_only_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)
+
+CLEANFILES =
+