summaryrefslogtreecommitdiffstats
path: root/xlators/Makefile.am
diff options
context:
space:
mode:
authorShyam <srangana@redhat.com>2015-10-08 13:59:44 -0400
committerJeff Darcy <jdarcy@redhat.com>2015-11-18 04:23:02 -0800
commit73200eaa8559c770a0ccc6e819cf791564592335 (patch)
tree4b05e7f22c6dc7dbb72b79e3b57278e05cd97f1c /xlators/Makefile.am
parent23440a73bc348bbc3bb43ec397f0639ee45865fc (diff)
core: Add experimental xlator directory
Added an experimental xlator directory under ./xlators/ The intent of this directory is presented in the README.md that accompanies this commit. This directory can be disabled from being compiled using, - configure --disable-experimental Change-Id: I047f380c91a082d111432f8bbdbd4d7bdcbaa809 Signed-off-by: Shyam <srangana@redhat.com> Reviewed-on: http://review.gluster.org/12321 Tested-by: NetBSD Build System <jenkins@build.gluster.org> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Reviewed-by: Avra Sengupta <asengupt@redhat.com> Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Diffstat (limited to 'xlators/Makefile.am')
-rw-r--r--xlators/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/xlators/Makefile.am b/xlators/Makefile.am
index 2b66201035d..ea1be844ef4 100644
--- a/xlators/Makefile.am
+++ b/xlators/Makefile.am
@@ -1,5 +1,9 @@
+if ENABLE_EXPERIMENTAL
+ EXPERIMENTAL = experimental
+endif
+
SUBDIRS = cluster storage protocol performance debug features encryption mount nfs mgmt system \
- playground meta
+ playground meta $(EXPERIMENTAL)
EXTRA_DIST = xlator.sym