summaryrefslogtreecommitdiffstats
path: root/tests/basic/gfapi/Makefile.am
diff options
context:
space:
mode:
authorRaghavendra Talur <rtalur@redhat.com>2016-03-10 18:01:33 +0530
committerRaghavendra Talur <rtalur@redhat.com>2016-05-04 11:47:11 -0700
commitf02e03374f43ee541a711ff79fd5a4815e55eea5 (patch)
tree820a9c2cf86fa33fbd13567d548c394cf40c3ada /tests/basic/gfapi/Makefile.am
parentef77131b44309404d7b1f492c8a92bc3dbf3e6b0 (diff)
tests: Backport all changes to tests dir
Test framework should be the same on all the branches. This is a copy of all the files under tests dir from master branch. New tests in master have not been backported, but changes to existing tests have been. Change-Id: I75747c525aabbd9247473dd29b3a0e7a7d93c827 BUG: 1316533 Signed-off-by: Raghavendra Talur <rtalur@redhat.com> Reviewed-on: http://review.gluster.org/13683 Smoke: Gluster Build System <jenkins@build.gluster.com> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'tests/basic/gfapi/Makefile.am')
-rw-r--r--tests/basic/gfapi/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/tests/basic/gfapi/Makefile.am b/tests/basic/gfapi/Makefile.am
index cdb0e543803..b166fcc3fa6 100644
--- a/tests/basic/gfapi/Makefile.am
+++ b/tests/basic/gfapi/Makefile.am
@@ -4,12 +4,17 @@
CFLAGS = -Wall -g $(shell pkg-config --cflags glusterfs-api)
LDFLAGS = $(shell pkg-config --libs glusterfs-api)
-BINARIES = upcall-cache-invalidate libgfapi-fini-hang anonymous_fd
+BINARIES = upcall-cache-invalidate libgfapi-fini-hang anonymous_fd seek
%: %.c
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
-all: $(BINARIES)
+all: check-pkgconfig $(BINARIES)
clean:
- -$(RM) $(BINARIES)
+ -$(RM) $(BINARIES)
+.phony: check-pkgconfig
+
+check-pkgconfig:
+ pkg-config --exists glusterfs-api