summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/src/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2014-05-16 16:58:20 +0200
committerAnand Avati <avati@redhat.com>2014-05-17 11:53:34 -0700
commit618d465295df02ae6d53be1327947a210bb8b47d (patch)
tree5d6a8a489ab3fc339d478cd16c7401736f749df8 /rpc/xdr/src/Makefile.am
parentaa85de4be3f96a140a69170330293bfdfa3d24e7 (diff)
NetBSD build fixes
- Shell scripts: == is specific to bash and ksh. Use = instead. - Shell scripts: use sh instead of bash if bash functionnality is not used - Shell scripts: ${var/search/replace} is specific to bash - sed: The -i option is specific to GNU sed. - Makefiles: $< outside of generic rules only work in GNU make. - xdrproc_t() is not universally defined as variadic. Do not specify third argument if it is not used - NetBSD FUSE specific: only include <perfuse.h> in FUSE client code, it harms in other locations - configure: Search for gettext() in libintl as NetBSD stores it there - Like MacOS X, NetBSD has unmount(2) and not umount(2) (un vs u) Some other build issues previously included in this change were removed: - __THROW macro, addressed in http://review.gluster.com/#/c/7757/ - getmntent() compat shared with MacOS X, in http://review.gluster.com/#/c/7722/ This patchset adds warning fixes for mount_glusterfs BUG: 764655 Change-Id: I2f1faf8ff96362d3e2baf237b943df619011f1f4 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/7783 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
Diffstat (limited to 'rpc/xdr/src/Makefile.am')
-rw-r--r--rpc/xdr/src/Makefile.am72
1 files changed, 36 insertions, 36 deletions
diff --git a/rpc/xdr/src/Makefile.am b/rpc/xdr/src/Makefile.am
index 1c70dc9db19..af9e15cfddf 100644
--- a/rpc/xdr/src/Makefile.am
+++ b/rpc/xdr/src/Makefile.am
@@ -23,91 +23,91 @@ CLEANFILES = $(XDRSOURCES) $(XDRHEADERS)
EXTRA_DIST = $(XDRGENFILES)
glusterfs3-xdr.c: glusterfs3-xdr.x glusterfs3-xdr.h
- @if test -f $<; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x}; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
glusterfs3-xdr.h: glusterfs3-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
cli1-xdr.c: cli1-xdr.x cli1-xdr.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
cli1-xdr.h: cli1-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
nlm4-xdr.c: nlm4-xdr.x nlm4-xdr.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
nlm4-xdr.h: nlm4-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
nsm-xdr.c: nsm-xdr.x nsm-xdr.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
nsm-xdr.h: nsm-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
rpc-common-xdr.c: rpc-common-xdr.x rpc-common-xdr.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
rpc-common-xdr.h: rpc-common-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
glusterd1-xdr.c: glusterd1-xdr.x glusterd1-xdr.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
glusterd1-xdr.h: glusterd1-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
acl3-xdr.c: acl3-xdr.x acl3-xdr.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
acl3-xdr.h: acl3-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
portmap-xdr.c: portmap-xdr.x portmap-xdr.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
portmap-xdr.h: portmap-xdr.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi
mount3udp.c: mount3udp.x mount3udp.h
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen source $< ; \
+ @if test -f ${@:.c=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen source ${@:.c=.x} ; \
fi
mount3udp.h: mount3udp.x
- @if test -f $< ; then \
- $(top_srcdir)/build-aux/xdrgen header $< ; \
+ @if test -f ${@:.h=.x} ; then \
+ $(top_srcdir)/build-aux/xdrgen header ${@:.h=.x} ; \
fi