summaryrefslogtreecommitdiffstats
path: root/libglusterfs/src/Makefile.am
diff options
context:
space:
mode:
authorSamikshan Bairagya <samikshan@gmail.com>2017-07-31 10:51:21 +0530
committerShyamsundar Ranganathan <srangana@redhat.com>2017-08-04 13:32:52 +0000
commit9bc0cf820ace2df58fc666f4ff4c7c50973b60a3 (patch)
tree69454561a59bad7eeb03b57f12c903099d1e37a3 /libglusterfs/src/Makefile.am
parent985d86bbc08bb44d105bcacd32750f1b1c505d43 (diff)
glusterd: Add geo-replication session details to get-state output
This commit adds support to the get-state CLI to capture details on geo-replication session as obtained in `gluster volume geo-replication status detail` in its output. > Reviewed-on: https://review.gluster.org/17941 > Smoke: Gluster Build System <jenkins@build.gluster.org> > Reviewed-by: Shubhendu Tripathi <shtripat@redhat.com> > CentOS-regression: Gluster Build System <jenkins@build.gluster.org> > Reviewed-by: Atin Mukherjee <amukherj@redhat.com> (cherry picked from commit 2e7daeffef05c6100cbcc39f1be62935711db3eb) Fixes: #291 Change-Id: I2fbcba70bfdaf439522637234805545194777ed4 Signed-off-by: Samikshan Bairagya <samikshan@gmail.com> Reviewed-on: https://review.gluster.org/17971 CentOS-regression: Gluster Build System <jenkins@build.gluster.org> Smoke: Gluster Build System <jenkins@build.gluster.org> Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
Diffstat (limited to 'libglusterfs/src/Makefile.am')
-rw-r--r--libglusterfs/src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/libglusterfs/src/Makefile.am b/libglusterfs/src/Makefile.am
index 768fe042a10..6c81142b826 100644
--- a/libglusterfs/src/Makefile.am
+++ b/libglusterfs/src/Makefile.am
@@ -38,9 +38,12 @@ libglusterfs_la_SOURCES = dict.c xlator.c logging.c \
compound-fop-utils.c throttle-tbf.c
nodist_libglusterfs_la_SOURCES = y.tab.c graph.lex.c defaults.c
-nodist_libglusterfs_la_HEADERS = y.tab.h
+nodist_libglusterfs_la_HEADERS = y.tab.h protocol-common.h
-BUILT_SOURCES = graph.lex.c defaults.c eventtypes.h
+BUILT_SOURCES = graph.lex.c defaults.c eventtypes.h protocol-common.h
+
+protocol-common.h: $(top_srcdir)/rpc/rpc-lib/src/protocol-common.h
+ cp $(top_srcdir)/rpc/rpc-lib/src/protocol-common.h .
libglusterfs_la_HEADERS = common-utils.h defaults.h default-args.h \
dict.h glusterfs.h hashfn.h timespec.h logging.h xlator.h \