summaryrefslogtreecommitdiffstats
path: root/extras/geo-rep/Makefile.am
diff options
context:
space:
mode:
authorAravinda VK <avishwan@redhat.com>2016-01-22 12:11:18 +0530
committerVenky Shankar <vshankar@redhat.com>2016-02-16 22:23:38 -0800
commitd7e052ee24b3e09f2e76c2fdb980e33e74d2a855 (patch)
treec12ee4be0f230d3c06f02c1b09137e02843c1361 /extras/geo-rep/Makefile.am
parentf4282bd927e2e0d826d62cf1192102382c5697b2 (diff)
geo-rep: Script to Schedule Geo-replication
This script can be used to run Geo-replication when required. can be scheduled using cron job to run Geo-replication. This script does the following, 1. Stop Geo-replication if Started 2. Start Geo-replication 3. Set Checkpoint 4. Check the Status and see Checkpoint is Complete.(LOOP) 5. If checkpoint complete, Stop Geo-replication Usage: python /usr/share/glusterfs/scripts/schedule_georep.py <MASTERVOL> \ <SLAVEHOST> <SLAVEVOL> For example, python /usr/share/glusterfs/scripts/schedule_georep.py gv1 fvm1 gv2 To schedule the Geo-replication to run once in a day using cron, # Run daily at 08:30pm 30 20 * * * root python /usr/share/glusterfs/scripts/schedule_georep.py \ --no-color gv1 fvm1 gv2 >> /var/log/glusterfs/schedule_georep.log 2>&1 BUG: 1300956 Change-Id: I6b1e2ddbf7fc09ef621499b57ae230fd4dbbd9a6 Signed-off-by: Aravinda VK <avishwan@redhat.com> Reviewed-on: http://review.gluster.org/13279 Smoke: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kotresh HR <khiremat@redhat.com> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Venky Shankar <vshankar@redhat.com>
Diffstat (limited to 'extras/geo-rep/Makefile.am')
-rw-r--r--extras/geo-rep/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/extras/geo-rep/Makefile.am b/extras/geo-rep/Makefile.am
index 662a84d4411..fb6664ef273 100644
--- a/extras/geo-rep/Makefile.am
+++ b/extras/geo-rep/Makefile.am
@@ -1,6 +1,6 @@
scriptsdir = $(datadir)/glusterfs/scripts
scripts_SCRIPTS = gsync-upgrade.sh generate-gfid-file.sh get-gfid.sh \
- slave-upgrade.sh
+ slave-upgrade.sh schedule_georep.py
scripts_PROGRAMS = gsync-sync-gfid
gsync_sync_gfid_CFLAGS = $(GF_CFLAGS) -Wall -I$(top_srcdir)/libglusterfs/src
@@ -10,4 +10,4 @@ gsync_sync_gfid_SOURCES = gsync-sync-gfid.c
gsync_sync_gfid_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
EXTRA_DIST = gsync-sync-gfid.c gsync-upgrade.sh generate-gfid-file.sh \
- get-gfid.sh slave-upgrade.sh
+ get-gfid.sh slave-upgrade.sh schedule_georep.py