summaryrefslogtreecommitdiffstats
path: root/extras/Makefile.am
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-08-14 13:06:26 -0700
committerHarshavardhana <harsha@harshavardhana.net>2014-09-03 11:01:45 -0700
commit025ae07850375cbf981ed335a4ddf702d54be6e3 (patch)
treea119246764dc98f0d0c7fb87572cd1b01bc18684 /extras/Makefile.am
parent845d6c76701a3de6a11b76b004176971411c714e (diff)
build: make GLUSTERD_WORKDIR rely on localstatedir
Backport from master branch - http://review.gluster.org/#/c/8246/ - Break-way from '/var/lib/glusterd' hard-coded previously, instead rely on 'configure' value from 'localstatedir' - Provide 's/lib/db' as default working directory for gluster management daemon for BSD and Darwin based installations - loff_t is really off_t on Darwin - fix-off the warnings generated by clang on FreeBSD/Darwin - Now 'tests/*' use GLUSTERD_WORKDIR a common variable for all platforms. - Define proper environment for running tests, define correct PATH and LD_LIBRARY_PATH when running tests, so that the desired version of glusterfs is used, regardless where it is installed. (Thanks to manu@netbsd.org for this additional work) Change-Id: I06e684ac4c26d1e74c9daf76753403ad15f79276 BUG: 1130308 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-on: http://review.gluster.org/8486 Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'extras/Makefile.am')
-rw-r--r--extras/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/extras/Makefile.am b/extras/Makefile.am
index 9395c9c1b65..74b6d17c16b 100644
--- a/extras/Makefile.am
+++ b/extras/Makefile.am
@@ -21,6 +21,6 @@ EXTRA_DIST = $(conf_DATA) specgen.scm MacOSX/Portfile glusterfs-mode.el \
command-completion/Makefile command-completion/README
install-data-local:
- $(mkdir_p) $(DESTDIR)$(localstatedir)/lib/glusterd/groups
+ $(mkdir_p) $(DESTDIR)$(GLUSTERD_WORKDIR)/groups
$(INSTALL_DATA) $(top_srcdir)/extras/group-virt.example \
- $(DESTDIR)$(localstatedir)/lib/glusterd/groups/virt
+ $(DESTDIR)$(GLUSTERD_WORKDIR)/groups/virt