summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2019-04-01 09:03:12 -0400
committerAtin Mukherjee <amukherj@redhat.com>2019-04-23 11:45:44 +0000
commit17992b69ccc729d59241ceff2aa480d1976e02fc (patch)
tree53a8c24b3902319129d4c2a0c01f7adbe43dc0e1 /configure.ac
parent4f0db1373be93e05b6fc451d2f07514704d3c4ca (diff)
build: conditional rpcbind for gnfs in glusterd.service
Don't Require: rpcbind in glusterd.service when gnfs isn't built Also add .../gluster-ta-volume.service to .gitignore See https://github.com/gluster/glusterfs/issues/647 Change-Id: I4d90cf66b12c378c0a9aace89a3a4bbf3784c284 Fixes: #647 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 89e330aaada..5d1e7bd6ead 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1347,14 +1347,17 @@ fi
dnl gnfs section
BUILD_GNFS="no"
+RPCBIND_SERVICE=""
AC_ARG_ENABLE([gnfs],
AC_HELP_STRING([--enable-gnfs],
[Enable legacy gnfs server xlator.]))
if test "x${with_server}" = "xyes" -a "x$enable_gnfs" = "xyes"; then
BUILD_GNFS="yes"
+ RPCBIND_SERVICE="rpcbind.service"
fi
AM_CONDITIONAL([BUILD_GNFS], [test x$BUILD_GNFS = xyes])
AC_SUBST(BUILD_GNFS)
+AC_SUBST(RPCBIND_SERVICE)
dnl end gnfs section
dnl Check for userspace-rcu