summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorShyamsundarR <srangana@redhat.com>2018-09-13 14:05:02 -0400
committerShyamsundarR <srangana@redhat.com>2018-09-17 10:31:19 -0400
commitc1314445cf008cf78a2157cb425bee836de5594c (patch)
treee603de84dbd8d5c1a7f6c328cb1eab9d2a9e47d9 /configure.ac
parentafc9f3b8716e88410ba50a6ce8abbfa186ee7c46 (diff)
core: remove experimental xlators and associated tests
experimental xlators removed from 5.0 Change-Id: I47219d8b95efc3d5875ec9224d1e79f8371e9f76 Updates: bz#1628620 Signed-off-by: ShyamsundarR <srangana@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 9358f849069..db88ff1d8b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,8 +124,6 @@ AC_CONFIG_FILES([Makefile
xlators/features/arbiter/src/Makefile
xlators/features/thin-arbiter/Makefile
xlators/features/thin-arbiter/src/Makefile
- xlators/experimental/fdl/Makefile
- xlators/experimental/fdl/src/Makefile
xlators/features/changelog/Makefile
xlators/features/changelog/src/Makefile
xlators/features/changelog/lib/Makefile
@@ -203,23 +201,6 @@ AC_CONFIG_FILES([Makefile
xlators/mgmt/Makefile
xlators/mgmt/glusterd/Makefile
xlators/mgmt/glusterd/src/Makefile
- xlators/experimental/Makefile
- xlators/experimental/jbr-client/Makefile
- xlators/experimental/jbr-client/src/Makefile
- xlators/experimental/jbr-server/Makefile
- xlators/experimental/jbr-server/src/Makefile
- xlators/experimental/dht2/Makefile
- xlators/experimental/dht2/dht2-client/Makefile
- xlators/experimental/dht2/dht2-client/src/Makefile
- xlators/experimental/dht2/dht2-server/Makefile
- xlators/experimental/dht2/dht2-server/src/Makefile
- xlators/experimental/posix2/Makefile
- xlators/experimental/posix2/ds/Makefile
- xlators/experimental/posix2/ds/src/Makefile
- xlators/experimental/posix2/mds/Makefile
- xlators/experimental/posix2/mds/src/Makefile
- xlators/experimental/posix2/common/Makefile
- xlators/experimental/posix2/common/src/Makefile
cli/Makefile
cli/src/Makefile
doc/Makefile
@@ -1529,18 +1510,6 @@ AC_SUBST(UNITTEST_LDFLAGS)
AC_SUBST(CFLAGS)
# end enable debug section
-# experimental section
-AC_ARG_ENABLE([experimental],
- AC_HELP_STRING([--disable-experimental],
- [Disable building experimental xlators]))
-
-BUILD_EXPERIMENTAL="yes"
-if test "x$enable_experimental" = "xno"; then
- BUILD_EXPERIMENTAL="no"
-fi
-AM_CONDITIONAL([ENABLE_EXPERIMENTAL], [test x$BUILD_EXPERIMENTAL = xyes])
-#end experimental section
-
# EC dynamic code generation section
EC_DYNAMIC_SUPPORT="none"
@@ -1758,7 +1727,6 @@ echo "POSIX ACLs : $BUILD_POSIX_ACLS"
echo "Data Classification : $BUILD_GFDB"
echo "SELinux features : $USE_SELINUX"
echo "firewalld-config : $BUILD_FIREWALLD"
-echo "Experimental xlators : $BUILD_EXPERIMENTAL"
echo "Events : $BUILD_EVENTS"
echo "EC dynamic support : $EC_DYNAMIC_SUPPORT"
echo "Use memory pools : $USE_MEMPOOL"