summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2017-01-20 11:11:46 -0500
committerShyamsundar Ranganathan <srangana@redhat.com>2018-05-09 17:41:37 +0000
commit641355a0fe5ae18d983ce91b46ecafd50d6eb5c1 (patch)
tree183fd289b55027e991e8c1a6060d5dad5f5d984c /configure.ac
parent98d3de5ce7b517cb2dfdd58b4111c26e6cefaf00 (diff)
core: remove experimental xlators and associated tests
experimental xlators removed from 4.1 Signed-off-by: ShyamsundarR <srangana@redhat.com> Change-Id: I34419ce22ca09b7626b8f9382c377a614fd9fed8 Updates: bz#1575386
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index b818d3fac0d..5c598717337 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,8 +124,6 @@ AC_CONFIG_FILES([Makefile
xlators/features/arbiter/src/Makefile
xlators/features/thin-arbiter/Makefile
xlators/features/thin-arbiter/src/Makefile
- xlators/experimental/fdl/Makefile
- xlators/experimental/fdl/src/Makefile
xlators/features/changelog/Makefile
xlators/features/changelog/src/Makefile
xlators/features/changelog/lib/Makefile
@@ -199,23 +197,6 @@ AC_CONFIG_FILES([Makefile
xlators/mgmt/Makefile
xlators/mgmt/glusterd/Makefile
xlators/mgmt/glusterd/src/Makefile
- xlators/experimental/Makefile
- xlators/experimental/jbr-client/Makefile
- xlators/experimental/jbr-client/src/Makefile
- xlators/experimental/jbr-server/Makefile
- xlators/experimental/jbr-server/src/Makefile
- xlators/experimental/dht2/Makefile
- xlators/experimental/dht2/dht2-client/Makefile
- xlators/experimental/dht2/dht2-client/src/Makefile
- xlators/experimental/dht2/dht2-server/Makefile
- xlators/experimental/dht2/dht2-server/src/Makefile
- xlators/experimental/posix2/Makefile
- xlators/experimental/posix2/ds/Makefile
- xlators/experimental/posix2/ds/src/Makefile
- xlators/experimental/posix2/mds/Makefile
- xlators/experimental/posix2/mds/src/Makefile
- xlators/experimental/posix2/common/Makefile
- xlators/experimental/posix2/common/src/Makefile
cli/Makefile
cli/src/Makefile
doc/Makefile
@@ -1498,18 +1479,6 @@ AC_SUBST(UNITTEST_LDFLAGS)
AC_SUBST(CFLAGS)
# end enable debug section
-# experimental section
-AC_ARG_ENABLE([experimental],
- AC_HELP_STRING([--disable-experimental],
- [Disable building experimental xlators]))
-
-BUILD_EXPERIMENTAL="yes"
-if test "x$enable_experimental" = "xno"; then
- BUILD_EXPERIMENTAL="no"
-fi
-AM_CONDITIONAL([ENABLE_EXPERIMENTAL], [test x$BUILD_EXPERIMENTAL = xyes])
-#end experimental section
-
# EC dynamic code generation section
EC_DYNAMIC_SUPPORT="none"
@@ -1693,7 +1662,6 @@ echo "POSIX ACLs : $BUILD_POSIX_ACLS"
echo "Data Classification : $BUILD_GFDB"
echo "SELinux features : $USE_SELINUX"
echo "firewalld-config : $BUILD_FIREWALLD"
-echo "Experimental xlators : $BUILD_EXPERIMENTAL"
echo "Events : $BUILD_EVENTS"
echo "EC dynamic support : $EC_DYNAMIC_SUPPORT"
echo "Use memory pools : $USE_MEMPOOL"