summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2017-01-20 11:11:46 -0500
committerShyamsundar Ranganathan <srangana@redhat.com>2018-01-31 17:50:48 +0000
commitfe2f1c995371444a2695994a700c0a6287eadd20 (patch)
tree9e944f0d9600a6a5baa2dea8b69a5a9d5ab496cf /configure.ac
parentc0a0a7089553ab265a21e6c9712a05d67e1726af (diff)
core: remove experimental xlators and associated tests
experimental xlators removed from 4.0 > Cherry picked from 4231c40973c60999f5ef759db450d25e129ef6ba: > Reviewed-on: https://review.gluster.org/17953 > Reviewed-by: jiffin tony Thottan <jthottan@redhat.com> Signed-off-by: ShyamsundarR <srangana@redhat.com> Change-Id: I34419ce22ca09b7626b8f9382c377a614fd9fed8 BUG: 1539842
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index ed84c661797..6bc5ebd39be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,8 +130,6 @@ AC_CONFIG_FILES([Makefile
xlators/features/Makefile
xlators/features/arbiter/Makefile
xlators/features/arbiter/src/Makefile
- xlators/experimental/fdl/Makefile
- xlators/experimental/fdl/src/Makefile
xlators/features/changelog/Makefile
xlators/features/changelog/src/Makefile
xlators/features/changelog/lib/Makefile
@@ -199,23 +197,6 @@ AC_CONFIG_FILES([Makefile
xlators/mgmt/Makefile
xlators/mgmt/glusterd/Makefile
xlators/mgmt/glusterd/src/Makefile
- xlators/experimental/Makefile
- xlators/experimental/jbr-client/Makefile
- xlators/experimental/jbr-client/src/Makefile
- xlators/experimental/jbr-server/Makefile
- xlators/experimental/jbr-server/src/Makefile
- xlators/experimental/dht2/Makefile
- xlators/experimental/dht2/dht2-client/Makefile
- xlators/experimental/dht2/dht2-client/src/Makefile
- xlators/experimental/dht2/dht2-server/Makefile
- xlators/experimental/dht2/dht2-server/src/Makefile
- xlators/experimental/posix2/Makefile
- xlators/experimental/posix2/ds/Makefile
- xlators/experimental/posix2/ds/src/Makefile
- xlators/experimental/posix2/mds/Makefile
- xlators/experimental/posix2/mds/src/Makefile
- xlators/experimental/posix2/common/Makefile
- xlators/experimental/posix2/common/src/Makefile
cli/Makefile
cli/src/Makefile
doc/Makefile
@@ -1461,18 +1442,6 @@ AC_SUBST(UNITTEST_LDFLAGS)
AC_SUBST(CFLAGS)
# end enable debug section
-# experimental section
-AC_ARG_ENABLE([experimental],
- AC_HELP_STRING([--disable-experimental],
- [Disable building experimental xlators]))
-
-BUILD_EXPERIMENTAL="yes"
-if test "x$enable_experimental" = "xno"; then
- BUILD_EXPERIMENTAL="no"
-fi
-AM_CONDITIONAL([ENABLE_EXPERIMENTAL], [test x$BUILD_EXPERIMENTAL = xyes])
-#end experimental section
-
# EC dynamic code generation section
EC_DYNAMIC_SUPPORT="none"
@@ -1656,7 +1625,6 @@ echo "POSIX ACLs : $BUILD_POSIX_ACLS"
echo "Data Classification : $BUILD_GFDB"
echo "SELinux features : $USE_SELINUX"
echo "firewalld-config : $BUILD_FIREWALLD"
-echo "Experimental xlators : $BUILD_EXPERIMENTAL"
echo "Events : $BUILD_EVENTS"
echo "EC dynamic support : $EC_DYNAMIC_SUPPORT"
echo "Use memory pools : $USE_MEMPOOL"