summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2014-07-23 15:11:56 +0200
committerVijay Bellur <vbellur@redhat.com>2014-07-23 16:13:38 -0700
commit1706151a42ce92057b01f4c6869bf66c65769021 (patch)
treebef7bb494a21ae63466c6efb8ce62d971b7b01c8 /configure.ac
parentf86d3facd31655a2b51af5a6910fc9355d442622 (diff)
Disable Erasure Code xlator if MMX is missing
Erasure Code xlator requires MMX instruction set. Disable building it if MMX is missing. BUG: 764655 Change-Id: Id9fe87db33e00c5630c1f3633ebd50fc4ebaec4d Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/8366 Reviewed-by: Xavier Hernandez <xhernandez@datalab.es> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c814a77689a..5cab04a7f22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,6 +323,9 @@ AC_CHECK_LIB([readline], [rl_do_undo], [RL_UNDO="yes"], [RL_UNDO="no"])
AC_CHECK_LIB([intl], [gettext])
+dnl Erasure Code xlator requires MMX instruction set
+AC_CHECK_HEADERS([xmmintrin.h], [enable_ec_xlator=yes], [enable_ec_xlator=no])
+
AC_CHECK_HEADERS([sys/xattr.h])
AC_CHECK_HEADERS([sys/ioctl.h], AC_DEFINE(HAVE_IOCTL_IN_SYS_IOCTL_H, 1, [have sys/ioctl.h]))
@@ -449,6 +452,14 @@ fi
AC_SUBST(FUSERMOUNT_SUBDIR)
#end FUSERMOUNT section
+# Erasure Code xlator section
+BUILD_EC_XLATOR=no
+if test "x$enable_ec_xlator" = "xyes" ; then
+ EC_XLATOR_SUBDIR=ec
+ BUILD_EC_XLATOR="yes"
+fi
+AC_SUBST(EC_XLATOR_SUBDIR)
+
# QEMU_BLOCK section
AC_ARG_ENABLE([qemu-block],
@@ -1079,4 +1090,5 @@ echo "Use syslog : $USE_SYSLOG"
echo "XML output : $BUILD_XML_OUTPUT"
echo "QEMU Block formats : $BUILD_QEMU_BLOCK"
echo "Encryption xlator : $BUILD_CRYPT_XLATOR"
+echo "Erasure Code xlator : $BUILD_EC_XLATOR"
echo