summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@f22node1.kkeithle.usersys.redhat.com>2015-03-13 14:22:14 -0400
committerKaleb S. KEITHLEY <kkeithle@f22node1.kkeithle.usersys.redhat.com>2015-03-13 14:32:49 -0400
commita0aa6fb91ac0cdd52769fa8c3cdbf63e48ff63db (patch)
tree3e97e08c087d8ada23ddb951e2a2802cf6cdb2ce /configure.ac
parentb037cfe399b91182d55708526645c72f324f98af (diff)
build: argp-standalone, conditional build and build with gcc-5
This patch is a backport of two patches on the master branch: 1) BZ 1086773, http://review.gluster.org/7440 commit 09d2dcac3a238cfe6bde1a7aed06facfa16caf20 Change-Id: Id0fcb717b5821d8a4c176e6274339f46b3a4a249 2) BZ 764655, http://review.gluster.org/6034 commit b2dfa011a3fdcb7d22764d143517d0fbd1c2a201 Change-Id: If5dfdc9c7427bd3d39d8da8f79e33ae2da6a3137 In summary: conditionally build argp-standalone, and address compile issues when compiling with gcc-5 Change-Id: Id0f36f0ca4a3775556c9ca524035cd27b4ded55d BUG: 1201898 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@f22node1.kkeithle.usersys.redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index def7a2754be..cd95c4707f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,6 +519,7 @@ if test "x${ac_cv_header_argp_h}" = "xno"; then
BUILD_ARGP_STANDALONE=yes
ARGP_STANDALONE_CPPFLAGS='-I${top_srcdir}/argp-standalone'
ARGP_STANDALONE_LDADD='${top_builddir}/argp-standalone/libargp.a'
+ ARGP_STANDALONE_DIR='${top_builddir}/argp-standalone'
fi
AC_SUBST(ARGP_STANDALONE_CPPFLAGS)