summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaushal M <kaushal@redhat.com>2017-05-04 12:15:09 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2017-05-05 11:39:28 +0000
commitde80a9153e3b681d8b83aa6164c94e2829b9cf49 (patch)
treec811c06876f415991b63c5b3b6388e3bfb3a2528 /configure.ac
parent93ecfcddbfc6bdc77a720f55dbd51fc256961d68 (diff)
rpc: Remove accidental IPV6 changes
They snuck in with the HALO patch (07cc8679c) Change-Id: I8ced6cbb0b49554fc9d348c453d4d5da00f981f6 BUG: 1447953 Signed-off-by: Kaushal M <kaushal@redhat.com> Reviewed-on: https://review.gluster.org/17174 Smoke: Gluster Build System <jenkins@build.gluster.org> Reviewed-by: Niels de Vos <ndevos@redhat.com> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.org> Reviewed-by: Amar Tumballi <amarts@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 4ffbcc83ef4..a1a5b3f034b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -309,13 +309,6 @@ else
CFLAGS="${CFLAGS} -g"
fi
-AC_ARG_WITH([fbextras], AC_HELP_STRING([--with-fbextras], [Enable Facebook specific extras.]))
-if test "x$with_fbextras" = "xyes"; then
- BUILD_FBEXTRAS=yes
-else
- BUILD_FBEXTRAS=no
-fi
-
AC_ARG_ENABLE([privport_tracking],
AC_HELP_STRING([--disable-privport_tracking],
[Disable internal tracking of privileged ports.]))
@@ -1070,13 +1063,6 @@ AC_SUBST(GF_DISTRIBUTION)
GF_HOST_OS=""
GF_LDFLAGS="-rdynamic"
-dnl include tirpc for FB builds
-if test "x$BUILD_FBEXTRAS" = "xyes"; then
- TIRPC_CFLAGS="-I/usr/include/tirpc"
- GF_LDFLAGS="-lfbtirpc $GF_LDFLAGS"
- GF_CFLAGS="$GF_CFLAGS $TIRPC_CFLAGS -DIPV6_DEFAULT"
-fi
-
dnl check for gcc -Werror=format-security
saved_CFLAGS=$CFLAGS
CFLAGS="-Wformat -Werror=format-security"
@@ -1555,7 +1541,6 @@ AC_SUBST([GF_CPPFLAGS])
AM_CONDITIONAL([GF_LINUX_HOST_OS], test "${GF_HOST_OS}" = "GF_LINUX_HOST_OS")
AM_CONDITIONAL([GF_DARWIN_HOST_OS], test "${GF_HOST_OS}" = "GF_DARWIN_HOST_OS")
AM_CONDITIONAL([GF_BSD_HOST_OS], test "${GF_HOST_OS}" = "GF_BSD_HOST_OS")
-AM_CONDITIONAL([GF_FBEXTRAS], test "${BUILD_FBEXTRAS}" = "yes")
AC_SUBST(GLUSTERD_WORKDIR)
AM_CONDITIONAL([GF_INSTALL_GLUSTERD_WORKDIR], test ! -d ${GLUSTERD_WORKDIR} && test -d ${sysconfdir}/glusterd )