summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2015-07-02 12:44:01 -0400
committerKaleb KEITHLEY <kkeithle@redhat.com>2015-07-06 14:20:39 -0700
commit88a719648475a6bf8d83c69a3b63b3d8a9a338cb (patch)
treee7192122bc2b1255f973b391dc3683c12e7e06f5 /configure.ac
parenta95f5651b8e2159eedb2ab87e2253a233d3ecfe7 (diff)
build: Mac OS X build issues, configure.ac
Mac has sqlite3, but no sysconf pkgconfig Change-Id: I516613656ea3877c1a019438352b3ef8b62da1f5 BUG: 1238796 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: http://review.gluster.org/11517 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 15 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9a0cb7ba91d..6d04a354889 100644
--- a/configure.ac
+++ b/configure.ac
@@ -737,13 +737,21 @@ AC_ARG_ENABLE([tiering],
[Disable data classification/tiering]),
[BUILD_GFDB="${enableval}"], [BUILD_GFDB="yes"])
-if test "x${BUILD_GFDB}" = "xyes"; then
- PKG_CHECK_MODULES([SQLITE], [sqlite3],
- AC_DEFINE(USE_GFDB, 1),
- AC_MSG_ERROR([pass --disable-tiering to build without sqlite]))
-else
- AC_DEFINE(USE_GFDB, 0, [no sqlite, gfdb is disabled])
-fi
+case $host_os in
+ darwin*)
+ SQLITE_LIBS="-lsqlite3"
+ AC_CHECK_HEADERS([sqlite3.h], AC_DEFINE(USE_GFDB, 1))
+ ;;
+ *)
+ if test "x${BUILD_GFDB}" = "xyes"; then
+ PKG_CHECK_MODULES([SQLITE], [sqlite3],
+ AC_DEFINE(USE_GFDB, 1),
+ AC_MSG_ERROR([pass --disable-tiering to build without sqlite]))
+ else
+ AC_DEFINE(USE_GFDB, 0, [no sqlite, gfdb is disabled])
+ fi
+ ;;
+esac
AC_SUBST(SQLITE_CFLAGS)
AC_SUBST(SQLITE_LIBS)