summaryrefslogtreecommitdiffstats
path: root/xlators/system/posix-acl/src/Makefile.am
diff options
context:
space:
mode:
authorKrutika Dhananjay <kdhananj@redhat.com>2013-11-28 16:47:09 +0530
committerVijay Bellur <vbellur@redhat.com>2013-11-28 08:46:33 -0800
commit72d3dde33bd12f4aea96d59097bef5df45672610 (patch)
tree560e354719395b4b6f99d972d566201600d02d43 /xlators/system/posix-acl/src/Makefile.am
parenta25d321bade8c3e7e07242f79ec9f1de2280af0f (diff)
posix-acl: Fix crash resulting from GF_FREE() done on a CALLOC'd object
The object in question was created in posix_acl_inherit () and was being GF_FREE'd as part of data_destroy(). Change-Id: Ibdb7c3b5c10ce447f061bde68452502e5170de92 BUG: 1035751 Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com> Reviewed-on: http://review.gluster.org/6377 Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'xlators/system/posix-acl/src/Makefile.am')
-rw-r--r--xlators/system/posix-acl/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/system/posix-acl/src/Makefile.am b/xlators/system/posix-acl/src/Makefile.am
index 11c939fa3..14ba51863 100644
--- a/xlators/system/posix-acl/src/Makefile.am
+++ b/xlators/system/posix-acl/src/Makefile.am
@@ -4,7 +4,7 @@ posix_acl_la_LDFLAGS = -module -avoid-version
posix_acl_la_SOURCES = posix-acl.c posix-acl-xattr.c
posix_acl_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-noinst_HEADERS = posix-acl.h posix-acl-xattr.h
+noinst_HEADERS = posix-acl.h posix-acl-xattr.h posix-acl-mem-types.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src