summaryrefslogtreecommitdiffstats
path: root/libglusterfsclient/src/Makefile.am
diff options
context:
space:
mode:
authorVijay Bellur <vijay@gluster.com>2009-12-18 12:38:04 +0000
committerVijay Bellur <vijay@dev.gluster.com>2009-12-20 21:38:36 -0800
commit96ae032a9cb9b198f31e26aba30a39e5148a2ba4 (patch)
tree81e731e4cbe0542dddb0cc62dd394a95768bb7e4 /libglusterfsclient/src/Makefile.am
parent2a51ab19e6370325a5ebac9ed63f8606738919ec (diff)
Support for Compilation on Solaris
This is based on patch at: http://node3.rnode.ru/glusterfs-3.0.0-p1.patch Thanks to Petrunin Egor <shellcode@mail.ru> for this patch. Signed-off-by: Vijay Bellur <vijay@gluster.com> Signed-off-by: Vijay Bellur <vijay@dev.gluster.com> BUG: 481 (Fix compilation failures in Solaris) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=481
Diffstat (limited to 'libglusterfsclient/src/Makefile.am')
-rw-r--r--libglusterfsclient/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libglusterfsclient/src/Makefile.am b/libglusterfsclient/src/Makefile.am
index 531f1fbb9..32811c0d5 100644
--- a/libglusterfsclient/src/Makefile.am
+++ b/libglusterfsclient/src/Makefile.am
@@ -4,7 +4,7 @@ libglusterfsclient_HEADERS = libglusterfsclient.h
libglusterfsclientdir = $(includedir)
libglusterfsclient_la_SOURCES = libglusterfsclient.c libglusterfsclient-dentry.c
-libglusterfsclient_la_CFLAGS = -fPIC -Wall -pthread
+libglusterfsclient_la_CFLAGS = -fPIC -Wall
libglusterfsclient_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
libglusterfsclient_la_CPPFLAGS = -D_FILE_OFFSET_BITS=64 -D$(GF_HOST_OS) -D__USE_FILE_OFFSET64 -D_GNU_SOURCE -I$(top_srcdir)/libglusterfs/src -DDATADIR=\"$(localstatedir)\" -DCONFDIR=\"$(sysconfdir)/glusterfs\" $(GF_CFLAGS)
libglusterfsclient_la_LDFLAGS = -shared -nostartfiles