summaryrefslogtreecommitdiffstats
path: root/tests/functional/arbiter
diff options
context:
space:
mode:
authorValerii Ponomarov <vponomar@redhat.com>2019-04-02 22:35:45 +0530
committervponomar <vponomar@redhat.com>2019-04-11 11:56:38 +0000
commit0b2c88ee59b52312c86bcceea1645a57671894af (patch)
tree4379ea502d11cea577ec4c3de9c606b9bfc231a4 /tests/functional/arbiter
parent5fe05c3d09126453423a3d2ee97a4586ec6592c1 (diff)
Fix support of OCP3.6 and 3.7
Project has lots of inconsistencies with OCP3.6 and 3.7 So, fix it. Change-Id: I8d38773637b779e1c2e1631568f100c1ab1fdd50
Diffstat (limited to 'tests/functional/arbiter')
-rw-r--r--tests/functional/arbiter/test_arbiter.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/functional/arbiter/test_arbiter.py b/tests/functional/arbiter/test_arbiter.py
index ad1094b..d8442b3 100644
--- a/tests/functional/arbiter/test_arbiter.py
+++ b/tests/functional/arbiter/test_arbiter.py
@@ -15,6 +15,7 @@ from openshiftstoragelibs.openshift_ops import (
wait_for_pod_be_ready,
wait_for_resource_absence,
)
+from openshiftstoragelibs.openshift_version import get_openshift_version
@ddt.ddt
@@ -23,6 +24,10 @@ class TestArbiterVolumeCreateExpandDelete(BaseClass):
def setUp(self):
super(TestArbiterVolumeCreateExpandDelete, self).setUp()
self.node = self.ocp_master_node[0]
+ if get_openshift_version() < "3.9":
+ self.skipTest("Arbiter feature cannot be used on OCP older "
+ "than 3.9, because 'volumeoptions' for Heketi "
+ "is not supported there.")
version = heketi_version.get_heketi_version(self.heketi_client_node)
if version < '6.0.0-11':
self.skipTest("heketi-client package %s does not support arbiter "