summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChetan Risbud <crisbud@redhat.com>2013-12-23 15:46:22 +0530
committerLuis Pabon <lpabon@redhat.com>2014-01-21 10:09:44 -0800
commit4b988ce3c598c8b59bd0ce77ab7854291c66549f (patch)
tree37186e691abd7444c800d02acadf3d84c4fc2b0e /setup.py
parent6a8e9a70e9489a8f17405adf64462899d6a4ca81 (diff)
Initial import of the swiftkerbauth
Imported code till commit f64a3354185f32928e2568d9ece4a52fa4746c05 Changed a code bit to import correct definitions. kerbauth unit tests do run along with gluster-swift. Install script does install swiftkerbauth. import swiftkerbauth from http://review.gluster.org/swiftkrbauth.git Change-Id: Ia89f2b77cc68df10dee2f41ce074f3381ac3c408 Signed-off-by: Chetan Risbud <crisbud@redhat.com> Reviewed-on: http://review.gluster.org/6597 Reviewed-by: Prashanth Pai <ppai@redhat.com> Reviewed-by: Luis Pabon <lpabon@redhat.com> Tested-by: Luis Pabon <lpabon@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a70cd29..0b52115 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-#!/usr/bin/python
# Copyright (c) 2013 Red Hat, Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
@@ -65,6 +64,8 @@ setup(
'paste.filter_factory': [
'gswauth=gluster.swift.common.middleware.gswauth.swauth.'
'middleware:filter_factory',
+ 'kerbauth=gluster.swift.common.middleware.'
+ 'swiftkerbauth.kerbauth:filter_factory',
],
},
)