summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorTimothy Asir <tjeyasin@redhat.com>2014-04-29 18:28:14 +0530
committerSahina Bose <sabose@redhat.com>2014-05-02 06:16:03 -0700
commitd646c986a3ba54570c9a0d367d106deeb0a80e38 (patch)
treeb721ee3b3d1b9f53e10ac417b77f5040a6e2a9bb /plugins/Makefile.am
parentccec0742af257e13effafa30a1184541c3cf5b65 (diff)
Run check gluster process status as a daemon
Enhanced to send specific gluster related process status only when there is a change detected in a service status or for any critical status to avoid too many logs in the nagios service side. Change-Id: I26e389ae2d1ccba1b5ccadc45d202d3b5219c74a Signed-off-by: Timothy Asir <tjeyasin@redhat.com> Reviewed-on: http://review.gluster.org/7602 Reviewed-by: Sahina Bose <sabose@redhat.com> Tested-by: Timothy Asir <tim.gluster@gmail.com>
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index de6bf41..c809b99 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -2,10 +2,14 @@ SUBDIRS = \
volcap \
$(NULL)
+initdir = $(sysconfdir)/init.d
+init_DATA = \
+ glusterpmd \
+ $(NULL)
+
cronddir = $(sysconfdir)/cron.d
crond_DATA = \
gluster-sysstat.crontab \
- gluster-proc.crontab \
$(NULL)
dist_glusternagiosplugins_PYTHON = \
@@ -29,5 +33,6 @@ dist_glusternagiosplugins_PYTHON = \
$(NULL)
EXTRA_DIST = \
+ $(init_DATA) \
$(crond_DATA) \
$(NULL)